libexpat-devel-2.2.4-alt1.x86_64.rpm


Advertisement

Description

libexpat-devel - Development files for Expat, an XML parser library for C

Property Value
Distribution ALT Linux Sisyphus
Repository Classic x86_64
Package filename libexpat-devel-2.2.4-alt1.x86_64.rpm
Package name libexpat-devel
Package version 2.2.4
Package release alt1
Package architecture x86_64
Package type rpm
Category Development/C
Homepage -
License -
Maintainer -
Download size 155.25 KB
Installed size 155.25 KB
Expat is a stream-oriented XML parser written in C.
This package is needed if you want to build programs which use Expat
library.

Alternatives

Package Version Architecture Repository
libexpat-devel-2.2.4-alt1.i586.rpm 2.2.4 i586 Classic
libexpat-devel - - -

Requires

Name Value
/usr/lib64/pkgconfig -
libexpat = 2.2.4-alt1
rpmlib(PayloadIsLzma) -

Provides

Name Value
expat-devel = 2.2.4
libexpat-devel = 2.2.4-alt1
pkgconfig(expat) = 2.2.4

Obsoletes

Name Value
expat-devel -

Download

Type URL
Mirror ftp.altlinux.org
Binary Package libexpat-devel-2.2.4-alt1.x86_64.rpm
Source Package expat-2.2.4-alt1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus x86_64 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install libexpat-devel rpm package:
    # sudo apt-get install libexpat-devel

Files

Path
/usr/include/expat.h
/usr/include/expat_config.h
/usr/include/expat_external.h
/usr/lib64/libexpat.so
/usr/lib64/pkgconfig/expat.pc
/usr/share/doc/expat-2.2.4/expat.png
/usr/share/doc/expat-2.2.4/reference.html
/usr/share/doc/expat-2.2.4/style.css
/usr/share/doc/expat-2.2.4/valid-xhtml10.png
/usr/share/doc/expat-2.2.4/examples/elements.c
/usr/share/doc/expat-2.2.4/examples/outline.c

Changelog

2017-08-21 - Alexey Tourbin <at@altlinux.ru> 2.2.4-alt1
- 2.1.0 -> 2.2.4
2012-09-12 - Dmitry V. Levin <ldv@altlinux.org> 2.1.0-alt1
- Updated to 2.1.0.
- Stopped build and packaging of libexpat-devel-static.
2011-02-05 - Alexey Tourbin <at@altlinux.ru> 2.0.1-alt5
- relocated shared library from /usr/lib to /lib
2010-10-11 - Alexey Tourbin <at@altlinux.ru> 2.0.1-alt4
- backported more bugfixes from cvs
- enabled "make check"
2009-05-06 - Dmitry V. Levin <ldv@altlinux.org> 2.0.1-alt3
- Fixed build with fresh libtool.
2009-04-10 - Alexey Tourbin <at@altlinux.ru> 2.0.1-alt2
- backported from cvs:
- parser crash with specially formatted UTF-8 sequences (expat-Bugs-1990430)
- xmlwf should return a non-zero code for parsing errors (expat-Bugs-2517938)
2009-04-10 - Alexey Tourbin <at@altlinux.ru> 2.0.1-alt1
- updated to 2.0.1 release
- removed ldconfig scriptlets
2007-04-08 - Alexey Tourbin <at@altlinux.ru> 2.0.1-alt0.1
- updated to 20061213 cvs snapshot

See Also

Package Description
libexplain-1.4-alt1.x86_64.rpm Library functions to explain system call errors
libexplain-devel-1.4-alt1.x86_64.rpm Development files for libexplain
libextractor-1.9-alt2.x86_64.rpm libextractor is a simple library for keyword extraction
libextractor-devel-1.9-alt2.x86_64.rpm libextractor development files and libraries
libexttextcat-3.4.5-alt1.x86_64.rpm Text categorisation library
libexttextcat-devel-3.4.5-alt1.x86_64.rpm Development files for libexttextcat
libexttextcat-tools-3.4.5-alt1.x86_64.rpm Tool for creating custom document fingerprints
libezV24-0.1.1-alt3.qa2.x86_64.rpm Serial ports interface library
libezV24-devel-0.1.1-alt3.qa2.x86_64.rpm Header files and libraries for libezV24 development
libf2c-ng-20160102-alt1.x86_64.rpm Shared library of f2c
libf2c-ng-devel-20160102-alt1.x86_64.rpm Headers of f2c
libf2c-ng-devel-static-20160102-alt1.x86_64.rpm Static library of f2c
libfaac-devel-1.28-alt2.x86_64.rpm Development files for the FAAC AAC coder library
libfaac0-1.28-alt2.x86_64.rpm Freeware Advanced Audio Coder (FAAC) libraries
libfaad-devel-2.7-alt6.x86_64.rpm Development files for the FAAD AAC decoder libraries
Advertisement
Advertisement