libgraphviz-devel-2.40.1-alt8.x86_64.rpm


Advertisement

Description

libgraphviz-devel - Header files and C programming manual for graphviz

Property Value
Distribution ALT Linux Sisyphus
Repository Classic x86_64
Package filename libgraphviz-devel-2.40.1-alt8.x86_64.rpm
Package name libgraphviz-devel
Package version 2.40.1
Package release alt8
Package architecture x86_64
Package type rpm
Category Development/C
Homepage -
License -
Maintainer -
Download size 159.16 KB
Installed size 159.16 KB
This package includes header files for graphviz

Alternatives

Package Version Architecture Repository
libgraphviz-devel-2.40.1-alt8.i586.rpm 2.40.1 i586 Classic
libgraphviz-devel - - -

Requires

Name Value
/usr/lib64/pkgconfig -
libgraphviz = 2.40.1-alt8:sisyphus+235250.100.1.1
rpmlib(PayloadIsLzma) -

Provides

Name Value
graphviz-devel = 2.40.1
libgraphviz-devel = 2.40.1-alt8:sisyphus+235250.100.1.1
pkgconfig(libcdt) = 2.40.1
pkgconfig(libcgraph) = 2.40.1
pkgconfig(libgvc) = 2.40.1
pkgconfig(libgvpr) = 2.40.1
pkgconfig(liblab_gamut) = 2.40.1
pkgconfig(libpathplan) = 2.40.1
pkgconfig(libxdot) = 2.40.1

Obsoletes

Name Value
graphviz-devel < 2.40.1

Download

Type URL
Mirror ftp.altlinux.org
Binary Package libgraphviz-devel-2.40.1-alt8.x86_64.rpm
Source Package graphviz-2.40.1-alt8.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus x86_64 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install libgraphviz-devel rpm package:
    # sudo apt-get install libgraphviz-devel

Files

Path
/usr/include/graphviz/arith.h
/usr/include/graphviz/cdt.h
/usr/include/graphviz/cgraph.h
/usr/include/graphviz/color.h
/usr/include/graphviz/geom.h
/usr/include/graphviz/graphviz_version.h
/usr/include/graphviz/gv.cpp
/usr/include/graphviz/gv.i
/usr/include/graphviz/gvc.h
/usr/include/graphviz/gvcext.h
/usr/include/graphviz/gvcjob.h
/usr/include/graphviz/gvcommon.h
/usr/include/graphviz/gvconfig.h
/usr/include/graphviz/gvplugin.h
/usr/include/graphviz/gvplugin_device.h
/usr/include/graphviz/gvplugin_layout.h
/usr/include/graphviz/gvplugin_loadimage.h
/usr/include/graphviz/gvplugin_render.h
/usr/include/graphviz/gvplugin_textlayout.h
/usr/include/graphviz/gvpr.h
/usr/include/graphviz/pack.h
/usr/include/graphviz/pathgeom.h
/usr/include/graphviz/pathplan.h
/usr/include/graphviz/textspan.h
/usr/include/graphviz/types.h
/usr/include/graphviz/usershape.h
/usr/include/graphviz/xdot.h
/usr/lib64/libcdt.so
/usr/lib64/libcgraph.so
/usr/lib64/libgvc.so
/usr/lib64/libgvpr.so
/usr/lib64/liblab_gamut.so
/usr/lib64/libpathplan.so
/usr/lib64/libxdot.so
/usr/lib64/pkgconfig/libcdt.pc
/usr/lib64/pkgconfig/libcgraph.pc
/usr/lib64/pkgconfig/libgvc.pc
/usr/lib64/pkgconfig/libgvpr.pc
/usr/lib64/pkgconfig/liblab_gamut.pc
/usr/lib64/pkgconfig/libpathplan.pc
/usr/lib64/pkgconfig/libxdot.pc
/usr/share/man/man3/cdt.3.xz
/usr/share/man/man3/cgraph.3.xz
/usr/share/man/man3/expr.3.xz
/usr/share/man/man3/gv.3guile.xz
/usr/share/man/man3/gv.3perl.xz
/usr/share/man/man3/gv.3python.xz
/usr/share/man/man3/gvc.3.xz
/usr/share/man/man3/gvpr.3.xz
/usr/share/man/man3/lab_gamut.3.xz
/usr/share/man/man3/pack.3.xz
/usr/share/man/man3/pathplan.3.xz
/usr/share/man/man3/xdot.3.xz

Changelog

2019-07-31 - Andrey Savchenko <bircoph@altlinux.org> 2.40.1-alt8
- remove e2k hack as it is needed no longer
2019-07-10 - Sergey V Turchin <zerg@altlinux.org> 2.40.1-alt7
- build with python3
2019-04-16 - Vitaly Lipatov <lav@altlinux.ru> 2.40.1-alt6
- add desktop file for dot -Txlib (ALT bug 27583)
- remove obsoleted linking patch
2019-04-16 - Vitaly Lipatov <lav@altlinux.ru> 2.40.1-alt5
- build without internal libltdl (ALT bug 36596)
- applied patches from Fedora
- CVE-2018-10196
2019-01-24 - Igor Vlasenko <viy@altlinux.ru> 2.40.1-alt4.1
- rebuild with new perl 5.28.1
2018-08-13 - Sergey Bolshakov <sbolshakov@altlinux.ru> 2.40.1-alt4
- rebuilt with recent guile
2018-07-07 - Vitaly Lipatov <lav@altlinux.ru> 2.40.1-alt3
- disable build gvedit (uses qt4 and was packed in the main package)
2018-06-10 - Michael Shigorin <mike@altlinux.org> 2.40.1-alt2
- disable -ffast-math (closes: #34101, but maybe not; thx lav@)
- E2K:
+ support e2kv4
+ prepare for lcc-1.23+
- minor spec cleanup
2018-01-12 - Andrew Savchenko <bircoph@altlinux.org> 2.40.1-alt1.1.1.2
- E2K: binaries must be compiled with -lcxa, because plugins use
C++ and may engage cxa.
2017-12-15 - Igor Vlasenko <viy@altlinux.ru> 2.40.1-alt1.1.1.1
- rebuild with new perl 5.26.1

See Also

Package Description
libgrapple-0.9.8-alt2.1.x86_64.rpm A network layer designed for games
libgrapple-devel-0.9.8-alt2.1.x86_64.rpm Header files for libgrapple
libgrass-7.6.1-alt1.x86_64.rpm GRASS (Geographic Resources Analysis Support System) runtime libraries
libgreedy-1.0.1-alt1.git79e69e3.x86_64.rpm Very fast greedy diffeomorphic registration code
libgreedy-devel-1.0.1-alt1.git79e69e3.x86_64.rpm Very fast greedy diffeomorphic registration code
libgrilo-0.3.10-alt1.x86_64.rpm Libraries files for Grilo framework
libgrilo-devel-0.3.10-alt1.x86_64.rpm Development files for Grilo framework
libgrilo-gir-0.3.10-alt1.x86_64.rpm GObject introspection data for the grilo library
libgringotts-1.2.1-alt1.1.qa1.x86_64.rpm libGringotts, a strongbox library
libgringotts-devel-1.2.1-alt1.1.qa1.x86_64.rpm Headers and static libraries for gringotts
libgrss-0.7.0-alt1.x86_64.rpm A Glib-based library to manage RSS and Atom feeds
libgrss-devel-0.7.0-alt1.x86_64.rpm Development files for libgrss
libgrss-gir-0.7.0-alt1.x86_64.rpm GObject introspection data for the libgrss library
libgs-9.28-alt0.rc1.1.x86_64.rpm Shared library for ghostscript
libgs-devel-9.28-alt0.rc1.1.x86_64.rpm Development library for ghostscript
Advertisement
Advertisement