libgtk+2-2.24.31-alt1.x86_64.rpm


Advertisement

Description

libgtk+2 - The GIMP ToolKit (GTK+), a library for creating GUIs

Distribution: ALT Linux Sisyphus
Repository: Classic x86_64
Package name: libgtk+2
Package version: 2.24.31
Package release: alt1
Package architecture: x86_64
Package type: rpm
Installed size: 5.38 MB
Download size: 5.38 MB
Official Mirror: ftp.altlinux.org
GTK+ is a multi-platform toolkit for creating graphical user interfaces. Offering a complete set of widgets, GTK+ is suitable for projects ranging from small one-off projects to complete application suites.

Alternatives

Provides

  • gtk+2 = 2.24.31
  • gtk-engines-pixmap = 2.24.31
  • gtk2 = 2.24.31
  • libgdk-x11-2.0.so.0()(64bit)
  • libgdk-x11-2.0.so.0(GDK_2.10)(64bit)
  • libgdk-x11-2.0.so.0(GDK_2.12)(64bit)
  • libgdk-x11-2.0.so.0(GDK_2.14)(64bit)
  • libgdk-x11-2.0.so.0(GDK_2.15)(64bit)
  • libgdk-x11-2.0.so.0(GDK_2.17.11)(64bit)
  • libgdk-x11-2.0.so.0(GDK_2.21.8)(64bit)
  • libgdk-x11-2.0.so.0(GDK_2.8)(64bit)
  • libgdk-x11-2.0.so.0(GDK_PRIVATE)(64bit)
  • libgtk+2 = 2.24.31-alt1
  • libgtk+2-common = 2.24.31
  • libgtk-x11-2.0.so.0()(64bit)
  • libgtk-x11-2.0.so.0(GTK_2.10)(64bit)
  • libgtk-x11-2.0.so.0(GTK_2.12)(64bit)
  • libgtk-x11-2.0.so.0(GTK_2.14)(64bit)
  • libgtk-x11-2.0.so.0(GTK_2.15.0)(64bit)
  • libgtk-x11-2.0.so.0(GTK_2.15.1)(64bit)
  • libgtk-x11-2.0.so.0(GTK_2.15.2)(64bit)
  • libgtk-x11-2.0.so.0(GTK_2.15.5)(64bit)
  • libgtk-x11-2.0.so.0(GTK_2.16.0)(64bit)
  • libgtk-x11-2.0.so.0(GTK_2.17.11)(64bit)
  • libgtk-x11-2.0.so.0(GTK_2.17.6)(64bit)
  • libgtk-x11-2.0.so.0(GTK_2.19.5)(64bit)
  • libgtk-x11-2.0.so.0(GTK_2.21.8)(64bit)
  • libgtk-x11-2.0.so.0(GTK_2.8)(64bit)
  • libgtk2 = 2.24.31

Obsoletes

  • gtk+2 < 2.24.31
  • gtk-engines-pixmap < 2.24.31
  • gtk2 < 2.24.31
  • libgtk+2-common <= 2.24.31
  • libgtk2 < 2.24.31

    Download

    Install Howto

    1. Add the following line to /etc/apt/sources.list:
      rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus x86_64 classic
      rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
      
    2. Update the package index:
      # sudo apt-get update
    3. Install libgtk+2 rpm package:
      # sudo apt-get install libgtk+2

    Files

    • /etc/gtk-2.0/gtkrc
    • /etc/gtk-2.0/im-multipress.conf
    • /usr/bin/gtk-query-immodules-2.0
    • /usr/lib/rpm/gtk-2.0-immodules-cache.filetrigger
    • /usr/lib64/libgdk-x11-2.0.so.0
    • /usr/lib64/libgdk-x11-2.0.so.0.2400.31
    • /usr/lib64/libgtk-x11-2.0.so.0
    • /usr/lib64/libgtk-x11-2.0.so.0.2400.31
    • /usr/lib64/gtk-2.0/modules
    • /usr/lib64/gtk-2.0/2.10.0/immodules.cache
    • /usr/lib64/gtk-2.0/2.10.0/engines/libpixmap.so
    • /usr/lib64/gtk-2.0/2.10.0/immodules/im-am-et.so
    • /usr/lib64/gtk-2.0/2.10.0/immodules/im-cedilla.so
    • /usr/lib64/gtk-2.0/2.10.0/immodules/im-cyrillic-translit.so
    • /usr/lib64/gtk-2.0/2.10.0/immodules/im-inuktitut.so
    • /usr/lib64/gtk-2.0/2.10.0/immodules/im-ipa.so
    • /usr/lib64/gtk-2.0/2.10.0/immodules/im-multipress.so
    • /usr/lib64/gtk-2.0/2.10.0/immodules/im-thai.so
    • /usr/lib64/gtk-2.0/2.10.0/immodules/im-ti-er.so
    • /usr/lib64/gtk-2.0/2.10.0/immodules/im-ti-et.so
    • /usr/lib64/gtk-2.0/2.10.0/immodules/im-viqr.so
    • /usr/lib64/gtk-2.0/2.10.0/immodules/im-xim.so
    • /usr/lib64/gtk-2.0/2.10.0/printbackends/libprintbackend-cups.so
    • /usr/lib64/gtk-2.0/2.10.0/printbackends/libprintbackend-file.so
    • /usr/lib64/gtk-2.0/2.10.0/printbackends/libprintbackend-lpr.so
    • /usr/share/gtk-2.0
    • /usr/share/doc/libgtk+2-2.24.31/AUTHORS
    • /usr/share/doc/libgtk+2-2.24.31/NEWS.bz2
    • /usr/share/doc/libgtk+2-2.24.31/README
    • /usr/share/man/man1/gtk-query-immodules-2.0.1.xz
    • /usr/share/themes/
    • /usr/share/themes/Default/
    • /usr/share/themes/Default/gtk-2.0-key/gtkrc
    • /usr/share/themes/Emacs/
    • /usr/share/themes/Emacs/gtk-2.0-key/gtkrc
    • /usr/share/themes/Raleigh/
    • /usr/share/themes/Raleigh/gtk-2.0/gtkrc

    Changelog

    2016-09-07 - Yuri N. Sedunov <aris@altlinux.org> 2.24.31-alt1 - 2.24.31 (CVE-2013-7447)

    2016-03-08 - Yuri N. Sedunov <aris@altlinux.org> 2.24.30-alt1 - 2.24.30

    2015-12-16 - Yuri N. Sedunov <aris@altlinux.org> 2.24.29-alt1 - 2.24.29

    2015-05-13 - Yuri N. Sedunov <aris@altlinux.org> 2.24.28-alt1 - 2.24.28

    2015-03-03 - Yuri N. Sedunov <aris@altlinux.org> 2.24.27-alt1 - 2.24.27

    2015-02-16 - Yuri N. Sedunov <aris@altlinux.org> 2.24.26-alt1 - 2.24.26

    2014-10-10 - Yuri N. Sedunov <aris@altlinux.org> 2.24.25-alt1 - 2.24.25

    2014-06-24 - Yuri N. Sedunov <aris@altlinux.org> 2.24.24-alt1 - 2.24.24

    2014-03-18 - Yuri N. Sedunov <aris@altlinux.org> 2.24.23-alt1 - 2.24.23

    2013-10-11 - Yuri N. Sedunov <aris@altlinux.org> 2.24.22-alt1 - 2.24.22

    Advertisement
    Advertisement