libiec61883-1.2.0-alt1.qa1.x86_64.rpm


Advertisement

Description

libiec61883 - Streaming library for IEEE1394

Property Value
Distribution ALT Linux Sisyphus
Repository Classic x86_64
Package name libiec61883
Package version 1.2.0
Package release alt1.qa1
Package architecture x86_64
Package type rpm
Installed size 103.35 KB
Download size 103.35 KB
Official Mirror ftp.altlinux.org
This library is an implementation of IEC 61883, part 1 (CIP, plug
registers, and CMP), part 2 (DV-SD), part 4 (MPEG2-TS), and part 6
(AMDTP). Outside of IIDC, nearly all FireWire multimedia devices use
IEC 61883 protocols.
The libiec61883 library provides a higher level API for streaming DV,
MPEG-2 and audio over Linux IEEE 1394. This includes both reception
and transmission. It uses the new "rawiso" API of libraw1394, which
transparently provides mmap-ed DMA for efficient data transfer. It
also represents the third generation of I/O technology for Linux 1394
for these media types thereby removing the complexities of additional
kernel modules, /dev nodes, and procfs. It also consolidates features
for plug control registers and connection management that previously
existed in experimental form in an unreleased version of libavc1394.

Alternatives

Package Version Architecture Repository
libiec61883-1.2.0-alt1.qa1.i586.rpm 1.2.0 i586 Classic
libiec61883 - - -

Requires

Name Value
/lib64/ld-linux-x86-64.so.2 -
libc.so.6(GLIBC_2.2.5)(64bit) -
libc.so.6(GLIBC_2.3.4)(64bit) -
libraw1394.so.11()(64bit) -
rpmlib(PayloadIsLzma) -
rpmlib(SetVersions) -
rtld(GNU_HASH) -

Provides

Name Value
libiec61883 = 1.2.0-alt1.qa1
libiec61883.so.0()(64bit) -

Download

Type URL
Binary Package libiec61883-1.2.0-alt1.qa1.x86_64.rpm
Source Package libiec61883-1.2.0-alt1.qa1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus x86_64 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install libiec61883 rpm package:
    # sudo apt-get install libiec61883

Files

Path
/usr/bin/plugctl
/usr/bin/plugreport
/usr/lib64/libiec61883.so.0
/usr/lib64/libiec61883.so.0.1.0
/usr/share/doc/libiec61883-1.2.0/AUTHORS
/usr/share/doc/libiec61883-1.2.0/ChangeLog
/usr/share/doc/libiec61883-1.2.0/NEWS
/usr/share/doc/libiec61883-1.2.0/README
/usr/share/man/man1/plugctl.1.xz
/usr/share/man/man1/plugreport.1.xz

Changelog

2016-04-16 - Dmitry V. Levin (QA) <qa_ldv@altlinux.org> 1.2.0-alt1.qa1
- NMU: removed redundant libraw1394 and libraw1394-devel requirements.
2013-08-04 - Vitaly Lipatov <lav@altlinux.ru> 1.2.0-alt1
- new version 1.2.0 (with rpmrb script)
- cleanup spec
2012-02-04 - Eugeny A. Rostovtsev (REAL) <real at altlinux.org> 1.1.0-alt1.qa2
- Removed bad RPATH
2010-11-26 - Igor Vlasenko <viy@altlinux.ru> 1.1.0-alt1.qa1
- rebuild for setversion provides
2008-12-13 - Yuri N. Sedunov <aris@altlinux.org> 1.1.0-alt1
- 1.1.0 release
- removed obsolete post{,un}_ldconfig calls

See Also

Package Description
libiec61883-devel-1.2.0-alt1.qa1.x86_64.rpm libiec61883 header files
libieee1284-0.2.11-alt3.x86_64.rpm A library for interfacing IEEE 1284-compatible devices
libieee1284-devel-0.2.11-alt3.x86_64.rpm Files for developing applications that use libieee1284
libiex12-2.2.0-alt1.1.x86_64.rpm IlmBase library
libiexmath12-2.2.0-alt1.1.x86_64.rpm IlmBase library
libifp-1.0.0.2-alt2_24.x86_64.rpm A general-purpose library-driver for iRiver's iFP portable audio players
libifp-devel-1.0.0.2-alt2_24.x86_64.rpm Headers and libraries for developing with libifp
libijs-0.35_9.25-alt2.x86_64.rpm Dynamic library for the IJS printer driver plug-in interface
libijs-devel-9.25-alt2.x86_64.rpm Headers and links for compiling against
libiksemel-1.4-alt5.x86_64.rpm iksemel Jabber Library
libiksemel-devel-1.4-alt5.x86_64.rpm iksemel Jabber Library
libilbc-0.6-alt7.x86_64.rpm Internet Low Bitrate Codec (iLBC) library
libilbc-devel-0.6-alt7.x86_64.rpm Library and header files for the iLBC library
libilbc-devel-static-0.6-alt7.x86_64.rpm Static library and header files for the iLBC library
libilbc1-0.0.2-alt3.x86_64.rpm iLBC is a library for the iLBC low bit rate speech codec
Advertisement
Advertisement