liblpsolve-5.5.2.5-alt1.x86_64.rpm


Advertisement

Description

liblpsolve - Library that solves linear programming problem

Property Value
Distribution ALT Linux Sisyphus
Repository Classic x86_64
Package filename liblpsolve-5.5.2.5-alt1.x86_64.rpm
Package name liblpsolve
Package version 5.5.2.5
Package release alt1
Package architecture x86_64
Package type rpm
Category Sciences/Mathematics
Homepage -
License -
Maintainer -
Download size 588.45 KB
Installed size 588.45 KB
Library that solves linear programming problem using Simplex algorithm.

Alternatives

Package Version Architecture Repository
liblpsolve-5.5.2.5-alt1.i586.rpm 5.5.2.5 i586 Classic
liblpsolve - - -

Requires

Name Value
libc.so.6(GLIBC_2.11)(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libc.so.6(GLIBC_2.2.5)(64bit) -
libc.so.6(GLIBC_2.3)(64bit) -
libc.so.6(GLIBC_2.3.4)(64bit) -
libc.so.6(GLIBC_2.4)(64bit) -
libc.so.6(GLIBC_2.7)(64bit) -
libdl.so.2(GLIBC_2.2.5)(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
rpmlib(PayloadIsLzma) -
rtld(GNU_HASH) -

Provides

Name Value
liblpsolve = 5.5.2.5-alt1
liblpsolve55.so()(64bit) -

Download

Type URL
Mirror ftp.altlinux.org
Binary Package liblpsolve-5.5.2.5-alt1.x86_64.rpm
Source Package lp_solve-5.5.2.5-alt1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus x86_64 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install liblpsolve rpm package:
    # sudo apt-get install liblpsolve

Files

Path
/usr/lib64/liblpsolve55.so

Changelog

2017-01-17 - Gleb F-Malinovskiy <glebfm@altlinux.org> 5.5.2.5-alt1
- Updated to 5.5.2.5.
2011-09-24 - Michael Shigorin <mike@altlinux.org> 5.5.2.0-alt1
- 5.5.2.0
- had to disable tests (no target as well as no makefile), alas
2009-09-18 - Michael Shigorin <mike@altlinux.org> 5.5.0.15-alt1
- 5.5.0.15 built for Sisyphus
+ based on *heavily* cleaned up 5.5.0.6 Daedalus spec
- I've seen no such violent macro exaltation before!!
+ also looked into current PLD and Rawhide specs
- dropped PLD spec from docs, cvs.pld-linux.org is better source
- dropped patch1 (seems applied upstream)
- tweaked patch0
+ then replaced patch0 with PLD one
+ then updated it for 5.5.0.15
+ then postponed shared colamd and stuck Fedora patch instead
- redone build in Fedora-like manner (so that it at least builds)
- introduced %check section
2006-05-22 - Aleksey Avdeev <solo@altlinux.ru> 5.5.0.6-alt1.0
- Porting in PLD (lp_solve-3.2-1), see lp_solve.PLD.spec (original spec
in docs)
- Use aclocal, libtoolize and automake if automake version >= "1.9.6"

See Also

Package Description
liblpsolve-devel-5.5.2.5-alt1.x86_64.rpm liblpsolve header files
liblqr-0.4.2-alt1.x86_64.rpm LiquidRescale library
liblqr-devel-0.4.2-alt1.x86_64.rpm LiquidRescale library development kit
liblrdf-0.6.1-alt1.x86_64.rpm Library for handling RDF descriptions of audio plugins
liblrdf-devel-0.6.1-alt1.x86_64.rpm Headers for developing programs that will use liblrdf
liblrzip-0.631-alt2.x86_64.rpm Library to add lrzip compression and decompression to other applications
liblrzip-devel-0.631-alt2.x86_64.rpm Development files for liblrzip
liblsan-devel-static-8-alt1.x86_64.rpm Dependency package for liblsan-devel-static
liblsan0-8.3.1-alt3.x86_64.rpm The Leak Sanitizer runtime library
liblsan4.9-devel-static-4.9.2-alt6.1.x86_64.rpm The Leak Sanitizer static library
liblsan5-devel-static-5.3.1-alt6.x86_64.rpm The Leak Sanitizer static library
liblsan6-devel-static-6.3.1-alt4.x86_64.rpm The Leak Sanitizer static library
liblsan7-devel-static-7.3.1-alt9.x86_64.rpm The Leak Sanitizer static library
liblsan8-devel-static-8.3.1-alt3.x86_64.rpm The Leak Sanitizer static library
liblscp-devel-0.5.8-alt1_2.x86_64.rpm Libraries for liblscp
Advertisement
Advertisement