libmcrypt-2.5.8-alt1.x86_64.rpm


Advertisement

Description

libmcrypt - Encryption/decryption library

Distribution: ALT Linux Sisyphus
Repository: Classic x86_64
Package name: libmcrypt
Package version: 2.5.8
Package release: alt1
Package architecture: x86_64
Package type: rpm
Installed size: 387.08 KB
Download size: 387.08 KB
Official Mirror: ftp.altlinux.org
The libmcrypt is a data encryption library. The library is thread safe and provides encryption and decryption functions. This version of the library supports many encryption algorithms and encryption modes. Some algorithms which are supported: SERPENT, RIJNDAEL, 3DES, GOST, SAFER+, CAST-256, RC2, XTEA, 3WAY, TWOFISH, BLOWFISH, ARCFOUR, WAKE and more.

Alternatives

Provides

  • libmcrypt = 2.5.8-alt1
  • libmcrypt.so.4()(64bit)

    Download

    Install Howto

    1. Add the following line to /etc/apt/sources.list:
      rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus x86_64 classic
      rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
      
    2. Update the package index:
      # sudo apt-get update
    3. Install libmcrypt rpm package:
      # sudo apt-get install libmcrypt

    Files

    • /usr/lib64/libmcrypt.so.4
    • /usr/lib64/libmcrypt.so.4.4.8
    • /usr/lib64/libmcrypt/arcfour.so
    • /usr/lib64/libmcrypt/blowfish-compat.so
    • /usr/lib64/libmcrypt/blowfish.so
    • /usr/lib64/libmcrypt/cast-128.so
    • /usr/lib64/libmcrypt/cast-256.so
    • /usr/lib64/libmcrypt/cbc.so
    • /usr/lib64/libmcrypt/cfb.so
    • /usr/lib64/libmcrypt/ctr.so
    • /usr/lib64/libmcrypt/des.so
    • /usr/lib64/libmcrypt/ecb.so
    • /usr/lib64/libmcrypt/enigma.so
    • /usr/lib64/libmcrypt/gost.so
    • /usr/lib64/libmcrypt/loki97.so
    • /usr/lib64/libmcrypt/ncfb.so
    • /usr/lib64/libmcrypt/nofb.so
    • /usr/lib64/libmcrypt/ofb.so
    • /usr/lib64/libmcrypt/rc2.so
    • /usr/lib64/libmcrypt/rijndael-128.so
    • /usr/lib64/libmcrypt/rijndael-192.so
    • /usr/lib64/libmcrypt/rijndael-256.so
    • /usr/lib64/libmcrypt/safer-sk128.so
    • /usr/lib64/libmcrypt/safer-sk64.so
    • /usr/lib64/libmcrypt/saferplus.so
    • /usr/lib64/libmcrypt/serpent.so
    • /usr/lib64/libmcrypt/stream.so
    • /usr/lib64/libmcrypt/threeway.so
    • /usr/lib64/libmcrypt/tripledes.so
    • /usr/lib64/libmcrypt/twofish.so
    • /usr/lib64/libmcrypt/wake.so
    • /usr/lib64/libmcrypt/xtea.so

    Changelog

    2012-05-27 - Andrew Clark <andyc@altlinux.ru> 2.5.8-alt1 - version update to 2.5.8

    2010-11-25 - Igor Vlasenko <viy@altlinux.ru> 2.5.7-alt2.qa2 - rebuild using girar-nmu to require/provide setversion by request of mithraen@

    2009-11-24 - Repocop Q. A. Robot <repocop@altlinux.org> 2.5.7-alt2.qa1 - NMU (by repocop): the following fixes applied: * post_ldconfig for libmcrypt * postun_ldconfig for libmcrypt * postclean-05-filetriggers for spec file

    2006-11-20 - Vitaly Lipatov <lav@altlinux.ru> 2.5.7-alt2 - change packager - fix bug #6977 - remove libdir/name from devel packages

    Advertisement
    Advertisement