libnss-role-0.2.8-alt3.x86_64.rpm


Advertisement

Description

libnss-role - NSS API library and admin tools for roles and privilegies

Property Value
Distribution ALT Linux Sisyphus
Repository Classic x86_64
Package name libnss-role
Package version 0.2.8
Package release alt3
Package architecture x86_64
Package type rpm
Installed size 61.50 KB
Download size 61.50 KB
Official Mirror ftp.altlinux.org
NSS API library and admin tools for roles and privilegies.

Alternatives

Package Version Architecture Repository
libnss-role-0.2.8-alt3.i586.rpm 0.2.8 i586 Classic
libnss-role - - -

Requires

Name Value
/etc/pam.d -
/lib64/ld-linux-x86-64.so.2 -
PAM(pam_deny.so) -
PAM(pam_permit.so) -
PAM(pam_rootok.so) -
chrooted >= 0.3.5-alt1
chrooted -
chrooted-resolv -
grep -
libc.so.6(GLIBC_2.2.5)(64bit) -
libc.so.6(GLIBC_2.3.4)(64bit) -
libc.so.6(GLIBC_2.4)(64bit) -
libc.so.6(GLIBC_2.7)(64bit) -
libpam.so.0()(64bit) -
libpam.so.0(LIBPAM_1.0)(64bit) -
libpam_misc.so.0()(64bit) -
libpam_misc.so.0(LIBPAM_MISC_1.0)(64bit) -
rpmlib(PayloadIsLzma) -
rpmlib(SetVersions) -
rtld(GNU_HASH) -
sed -

Provides

Name Value
libnss-role = 0.2.8-alt3
libnss_role.so.2()(64bit) -
librole.so.0()(64bit) -
pam0(roleadd) -
pam0(roledel) -

Download

Type URL
Binary Package libnss-role-0.2.8-alt3.x86_64.rpm
Source Package libnss-role-0.2.8-alt3.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus x86_64 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install libnss-role rpm package:
    # sudo apt-get install libnss-role

Files

Path
/etc/role
/etc/pam.d/roleadd
/etc/pam.d/roledel
/lib64/libnss_role.so.2
/lib64/libnss_role.so.2.0.0
/usr/bin/rolelst
/usr/lib64/librole.so.0
/usr/lib64/librole.so.0.0.0
/usr/sbin/roleadd
/usr/sbin/roledel
/usr/share/man/man8/roleadd.8.xz
/usr/share/man/man8/roledel.8.xz
/usr/share/man/man8/rolelst.8.xz

Changelog

2017-05-02 - Gleb F-Malinovskiy <glebfm@altlinux.org> 0.2.8-alt3
- Fixed fgetc and realloc usage.
2013-07-11 - Pavel Shilovsky <piastry@altlinux.org> 0.2.8-alt2
- Merge git.alt branch
2013-07-01 - Pavel Shilovsky <piastry@altlinux.org> 0.2.8-alt1
- Skip blank lines in the config file
2011-11-19 - Evgeny Sinelnikov <sin@altlinux.ru> 0.2.7-alt4
- Fix devel-file-in-non-devel-package rpmlint violation
- Add comments to configuration due rpmlint violation
2011-02-26 - Pavel Shilovsky <piastry@altlinux.org> 0.2.7-alt3
- Replace /etc/nsswitch.conf with %_sysconfigdir/nsswitch.conf
2011-01-15 - Pavel Shilovsky <piastry@altlinux.org> 0.2.7-alt2
- Fix module version
2010-11-29 - Pavel Shilovsky <piastry@altlinux.org> 0.2.7-alt1
- Add comment support
2010-11-03 - Pavel Shilovsky <piastry@altlinux.org> 0.2.6-alt2
- Fix version
2010-11-02 - Pavel Shilovsky <piastry@altlinux.org> 0.2.6-alt1
- Bug fixing
2010-10-24 - Pavel Shilovsky <piastry@altlinux.org> 0.2.5-alt1
- Add new parsing rules
- Update mans
- Code style and bug fixing
- Delete cpp implementation

See Also

Package Description
libnss-role-devel-0.2.8-alt3.x86_64.rpm Header for developing applications managing Roles
libnss-sysinit-3.36.4-alt1.x86_64.rpm System NSS Initilization
libnss-systemd-238-alt8.x86_64.rpm nss-systemd providing UNIX user and group name resolution for dynamic users and groups
libnss-tartarus-0.1.1-alt3.6.1.2.x86_64.rpm NSS library module for Tartarus
libntdb-1.0-alt1.x86_64.rpm A not-so trivial database
libntdb-devel-1.0-alt1.x86_64.rpm Developer tools for the NTDB library
libntfs-3g-2017.3.23-alt1.x86_64.rpm Shared libraries for ntfs-3g
libntfs-3g-devel-2017.3.23-alt1.x86_64.rpm Development files for ntfs-3g
libntirpc-1.6.2-alt1.x86_64.rpm New Transport Independent RPC Library
libntirpc-devel-1.6.2-alt1.x86_64.rpm Development headers for libntirpc
libntlm-1.3-alt1.x86_64.rpm NTLM authentication library
libntlm-devel-1.3-alt1.x86_64.rpm Files for development of libntlm-based applications
libnuma-2.0.11-alt1.x86_64.rpm Shared libraries for numactl
libnuma-devel-2.0.11-alt1.x86_64.rpm Development files for numactl
libnumpy-1.13.3-alt2.1.1.x86_64.rpm Shared libraries of NumPy
Advertisement
Advertisement