liboniguruma-devel-6.9.3-alt1.x86_64.rpm


Advertisement

Description

liboniguruma-devel - Development files for oniguruma

Property Value
Distribution ALT Linux Sisyphus
Repository Classic x86_64
Package filename liboniguruma-devel-6.9.3-alt1.x86_64.rpm
Package name liboniguruma-devel
Package version 6.9.3
Package release alt1
Package architecture x86_64
Package type rpm
Category Development/Other
Homepage -
License -
Maintainer -
Download size 96.57 KB
Installed size 96.57 KB
The liboniguruma-devel package contains libraries and header files for
developing applications that use oniguruma.

Alternatives

Package Version Architecture Repository
liboniguruma-devel-6.9.3-alt1.i586.rpm 6.9.3 i586 Classic
liboniguruma-devel - - -

Requires

Name Value
/usr/lib64/pkgconfig -
coreutils -
liboniguruma5 = 6.9.3-alt1:sisyphus+235963.100.1.1
rpmlib(PayloadIsLzma) -

Provides

Name Value
libOniGuruma-devel = 6.9.3-alt1
liboniguruma-devel = 6.9.3-alt1:sisyphus+235963.100.1.1
oniguruma-devel = 6.9.3-alt1
pkgconfig(oniguruma) = 6.9.3

Obsoletes

Name Value
libOniGuruma-devel -
oniguruma-devel -

Download

Type URL
Mirror ftp.altlinux.org
Binary Package liboniguruma-devel-6.9.3-alt1.x86_64.rpm
Source Package oniguruma-6.9.3-alt1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus x86_64 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install liboniguruma-devel rpm package:
    # sudo apt-get install liboniguruma-devel

Files

Path
/usr/bin/onig-config
/usr/include/oniggnu.h
/usr/include/onigposix.h
/usr/include/oniguruma.h
/usr/lib64/libonig.so
/usr/lib64/pkgconfig/oniguruma.pc
/usr/share/doc/liboniguruma-devel-6.9.3/API
/usr/share/doc/liboniguruma-devel-6.9.3/FAQ
/usr/share/doc/liboniguruma-devel-6.9.3/RE

Changelog

2019-08-13 - Anton Farygin <rider@altlinux.ru> 6.9.3-alt1
- 6.9.3
2019-05-11 - Anton Farygin <rider@altlinux.ru> 6.9.2-alt1
- 6.9.2
2018-12-20 - Anton Farygin <rider@altlinux.ru> 6.9.1-alt2
- fixed build (thanks bash4 for finding old and unused patch in subshell)
- ubt cleanup
2018-12-14 - Anton Farygin <rider@altlinux.ru> 6.9.1-alt1
- 6.9.1
2018-09-21 - Anton Farygin <rider@altlinux.ru> 6.9.0-alt1
- 6.9.0
2018-05-04 - Anton Farygin <rider@altlinux.ru> 6.8.2-alt1
- new version
2018-04-05 - Anton Farygin <rider@altlinux.ru> 6.8.1-alt1
- new version
- the library package was renamed for compatability with ALT Linux shared policy
2018-01-29 - Anton Farygin <rider@altlinux.ru> 6.7.1-alt1
- new version
2017-10-02 - Anton Farygin <rider@altlinux.ru> 6.6.1-alt1
- new version
2017-07-12 - Anton Farygin <rider@altlinux.ru> 6.4.0-alt1
- new version with security fixes (CVE-2017-9224, CVE-2017-9225, CVE-2017-9226, CVE-2017-9227, CVE-2017-9228, CVE-2017-9229)

See Also

Package Description
liboniguruma5-6.9.3-alt1.x86_64.rpm Regular expressions library
libonsetsds-2011.02.10-alt1.x86_64.rpm Musical onset detection library
libonsetsds-devel-2011.02.10-alt1.x86_64.rpm Development files of musical onset detection library
libopagent-0.9.9-alt3.x86_64.rpm Libraries required for profiling Java and other JITed code
libopagent-devel-0.9.9-alt3.x86_64.rpm Files for development with libopagent
libopagent-devel-static-0.9.9-alt3.x86_64.rpm Static libraries required for profiling Java and other JITed code
libopenCOLLADA-0-alt7.gitcaad49c.x86_64.rpm Collada 3D import and export libraries
libopenCOLLADA-devel-0-alt7.gitcaad49c.x86_64.rpm Include files for openCOLLADA development
libopenCOLLADA-utils-0-alt7.gitcaad49c.x86_64.rpm XML validator for COLLADA files
libopenal-devel-1.19.1-alt1.x86_64.rpm Headers for developing programs that will use OpenAL
libopenal1-1.19.1-alt1.x86_64.rpm Main library for OpenAL, a free 3D sound library
libopenaptx-1.0.0-alt0.1.gebcf004.x86_64.rpm reverse-engineered apt-X codec library
libopenaptx-devel-1.0.0-alt0.1.gebcf004.x86_64.rpm apt-X header files
libopenaptx-tools-1.0.0-alt0.1.gebcf004.x86_64.rpm apt-X library tools
libopenbabel-2.4.1-alt6.x86_64.rpm Shared libraries for programs which will use Open Babel
Advertisement
Advertisement