libpopt-1.16-alt1.x86_64.rpm


Advertisement

Description

libpopt - A C library for parsing command line parameters

Property Value
Distribution ALT Linux Sisyphus
Repository Classic x86_64
Package filename libpopt-1.16-alt1.x86_64.rpm
Package name libpopt
Package version 1.16
Package release alt1
Package architecture x86_64
Package type rpm
Category System/Libraries
Homepage -
License -
Maintainer -
Download size 110.04 KB
Installed size 110.04 KB
Popt is a C library for parsing command line parameters.  Popt was
heavily influenced by the getopt() and getopt_long() functions, but it
improves on them by allowing more powerful argument expansion.  Popt
can parse arbitrary argv[] style arrays and automatically set
variables based on command line arguments.  Popt allows command line
arguments to be aliased via configuration files and includes utility
functions for parsing arbitrary strings into argv[] arrays using
shell-like rules.

Alternatives

Package Version Architecture Repository
libpopt-1.16-alt1.i586.rpm 1.16 i586 Classic
libpopt - - -

Requires

Name Value
libc.so.6(GLIBC_2.14)(64bit) -
libc.so.6(GLIBC_2.17)(64bit) -
libc.so.6(GLIBC_2.2.5)(64bit) -
libc.so.6(GLIBC_2.3)(64bit) -
libc.so.6(GLIBC_2.3.4)(64bit) -
libc.so.6(GLIBC_2.4)(64bit) -
libc.so.6(GLIBC_2.8)(64bit) -
rpmlib(PayloadIsLzma) -
rtld(GNU_HASH) -

Provides

Name Value
libpopt = 1:1.16-alt1
libpopt.so.0()(64bit) -
libpopt.so.0(LIBPOPT_0)(64bit) -
popt = 1.16-alt1

Obsoletes

Name Value
popt -

Download

Type URL
Mirror ftp.altlinux.org
Binary Package libpopt-1.16-alt1.x86_64.rpm
Source Package libpopt-1.16-alt1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus x86_64 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install libpopt rpm package:
    # sudo apt-get install libpopt

Files

Path
/lib64/libpopt.so.0
/lib64/libpopt.so.0.0.0
/usr/share/locale/cs/LC_MESSAGES/popt.mo
/usr/share/locale/da/LC_MESSAGES/popt.mo
/usr/share/locale/de/LC_MESSAGES/popt.mo
/usr/share/locale/eo/LC_MESSAGES/popt.mo
/usr/share/locale/es/LC_MESSAGES/popt.mo
/usr/share/locale/fi/LC_MESSAGES/popt.mo
/usr/share/locale/fr/LC_MESSAGES/popt.mo
/usr/share/locale/ga/LC_MESSAGES/popt.mo
/usr/share/locale/gl/LC_MESSAGES/popt.mo
/usr/share/locale/hu/LC_MESSAGES/popt.mo
/usr/share/locale/id/LC_MESSAGES/popt.mo
/usr/share/locale/is/LC_MESSAGES/popt.mo
/usr/share/locale/it/LC_MESSAGES/popt.mo
/usr/share/locale/ja/LC_MESSAGES/popt.mo
/usr/share/locale/ko/LC_MESSAGES/popt.mo
/usr/share/locale/lv/LC_MESSAGES/popt.mo
/usr/share/locale/nb/LC_MESSAGES/popt.mo
/usr/share/locale/nl/LC_MESSAGES/popt.mo
/usr/share/locale/pl/LC_MESSAGES/popt.mo
/usr/share/locale/pt/LC_MESSAGES/popt.mo
/usr/share/locale/ro/LC_MESSAGES/popt.mo
/usr/share/locale/ru/LC_MESSAGES/popt.mo
/usr/share/locale/sk/LC_MESSAGES/popt.mo
/usr/share/locale/sl/LC_MESSAGES/popt.mo
/usr/share/locale/sv/LC_MESSAGES/popt.mo
/usr/share/locale/th/LC_MESSAGES/popt.mo
/usr/share/locale/tr/LC_MESSAGES/popt.mo
/usr/share/locale/uk/LC_MESSAGES/popt.mo
/usr/share/locale/vi/LC_MESSAGES/popt.mo
/usr/share/locale/wa/LC_MESSAGES/popt.mo
/usr/share/locale/zh_CN/LC_MESSAGES/popt.mo
/usr/share/locale/zh_TW/LC_MESSAGES/popt.mo

Changelog

2017-06-20 - Anton Farygin <rider@altlinux.ru> 1:1.16-alt1
- 1.16 (closes: 32186).
2016-02-09 - Michael Shigorin <mike@altlinux.org> 1:1.14-alt10
- BOOTSTRAP: fixed --without apidocs build.
- Replaced bzip2 with xz while at that.
2013-10-30 - Dmitry V. Levin <ldv@altlinux.org> 1:1.14-alt9
- Fixed build with new automake.
2013-04-08 - Dmitry V. Levin <ldv@altlinux.org> 1:1.14-alt8
- Fixed build with new gettext.
2013-03-25 - Dmitry V. Levin <ldv@altlinux.org> 1:1.14-alt7
- Added secure_getenv support.
2011-02-25 - Dmitry V. Levin <ldv@altlinux.org> 1:1.14-alt6
- Rebuilt for debuginfo.
2010-10-12 - Dmitry V. Levin <ldv@altlinux.org> 1:1.14-alt5
- Rebuilt for soname set-versions.
2008-12-14 - Dmitry V. Levin <ldv@altlinux.org> 1:1.14-alt4
- Removed obsolete %post_ldconfig/%postun_ldconfig calls.
- Packaged -doc subpackage as noarch.

See Also

Package Description
libpopt-devel-1.16-alt1.x86_64.rpm Developement environment for the popt library
libpopt-devel-static-1.16-alt1.x86_64.rpm Static popt library
libportaudio2-19-alt7.x86_64.rpm PortAudio is a free, cross platform, open-source, audio I/O library
libportaudio2-devel-19-alt7.x86_64.rpm Static library and header files for the PortAudio library
libportmidi-217-alt3.x86_64.rpm Platform Independent Library for MIDI I/O
libportmidi-devel-217-alt3.x86_64.rpm Development files for PortMidi
libpostproc-devel-4.2.1-alt1.x86_64.rpm Development files for libpostproc
libpostproc54-3.3.9-alt2.x86_64.rpm FFmpeg postprocessing library
libpostproc55-4.2.1-alt1.x86_64.rpm FFmpeg postprocessing library
libpotrace-1.15-alt2.x86_64.rpm Potrace library
libpotrace-devel-1.15-alt2.x86_64.rpm Potrace development files
libpowerdevilconfigcommonprivate5-5.16.5-alt1.x86_64.rpm KF5 library
libpowerdevilcore2-5.16.5-alt1.x86_64.rpm KF5 library
libpowerdevilui5-5.16.5-alt1.x86_64.rpm KF5 library
libpq5-12.0-alt2.x86_64.rpm The shared libraries required for any PostgreSQL clients
Advertisement
Advertisement