libproxy-0.4.15-alt1.x86_64.rpm


Advertisement

Description

libproxy - A library handling all the details of proxy configuration

Property Value
Distribution ALT Linux Sisyphus
Repository Classic x86_64
Package name libproxy
Package version 0.4.15
Package release alt1
Package architecture x86_64
Package type rpm
Installed size 144.14 KB
Download size 144.14 KB
Official Mirror ftp.altlinux.org
libproxy offers the following features:
* extremely small core footprint (< 35K)
* no external dependencies within libproxy core
(libproxy plugins may have dependencies)
* only 3 functions in the stable external API
* dynamic adjustment to changing network topology
* a standard way of dealing with proxy settings across all scenarios
* a sublime sense of joy and accomplishment

Alternatives

Package Version Architecture Repository
libproxy-0.4.15-alt1.i586.rpm 0.4.15 i586 Classic
libproxy - - -

Requires

Name Value
libc.so.6(GLIBC_2.14)(64bit) -
libc.so.6(GLIBC_2.2.5)(64bit) -
libc.so.6(GLIBC_2.4)(64bit) -
libdl.so.2(GLIBC_2.2.5)(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(CXXABI_1.3.1)(64bit) -
libstdc++.so.6(CXXABI_1.3.9)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.11)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.20)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.21)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.9)(64bit) -
rpmlib(PayloadIsLzma) -
rtld(GNU_HASH) -

Provides

Name Value
libproxy = 0.4.15-alt1
libproxy.so.1()(64bit) -

Download

Type URL
Binary Package libproxy-0.4.15-alt1.x86_64.rpm
Source Package libproxy-0.4.15-alt1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus x86_64 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install libproxy rpm package:
    # sudo apt-get install libproxy

Files

Path
/usr/lib64/libproxy.so.1
/usr/lib64/libproxy.so.1.0.0
/usr/lib64/libproxy/
/usr/lib64/libproxy/0.4.15/modules
/usr/share/doc/libproxy-0.4.15/AUTHORS
/usr/share/doc/libproxy-0.4.15/README

Changelog

2017-06-16 - Alexey Shabalin <shaba@altlinux.ru> 0.4.15-alt1
- 0.4.15
2017-01-20 - Alexey Shabalin <shaba@altlinux.ru> 0.4.14-alt1
- 0.4.14
- add python3 package
2016-06-14 - Alexey Shabalin <shaba@altlinux.ru> 0.4.13-alt1
- 0.4.13
2016-03-16 - Alexey Shabalin <shaba@altlinux.ru> 0.4.12-alt1
- 0.4.12
2013-01-29 - Alexey Shabalin <shaba@altlinux.ru> 0.4.11-alt1
- 0.4.11
2012-10-26 - Alexey Shabalin <shaba@altlinux.ru> 0.4.10-alt1
- 0.4.10
2012-01-17 - Alexey Shabalin <shaba@altlinux.ru> 0.4.7-alt3
- disable build with RPATH
2011-10-31 - Vitaly Kuznetsov <vitty@altlinux.ru> 0.4.7-alt2.1
- Rebuild with Python-2.7
2011-10-24 - Alexey Shabalin <shaba@altlinux.ru> 0.4.7-alt2
- build svn snapshot (20110903)
- rebuild with new libwebkitgtk-1.6.1
- build with libmozjs
2011-08-22 - Alexey Shabalin <shaba@altlinux.ru> 0.4.7-alt1
- 0.4.7
- build without mozjs support
- build without gnome and webkitgtk support (but with gnome3 and webkitgtk3)

See Also

Package Description
libproxy-devel-0.4.15-alt1.x86_64.rpm Development files for libproxy
libproxy-gnome3-0.4.15-alt1.x86_64.rpm Libproxy module for gnome3 configuration
libproxy-kde-0.4.15-alt1.x86_64.rpm Libproxy module for kde configuration
libproxy-mozjs-0.4.15-alt1.x86_64.rpm Libproxy module to support wpad/pac parsing via Mozilla JavaScript Engine
libproxy-networkmanager-0.4.15-alt1.x86_64.rpm Libproxy module for networkmanager configuration
libproxy-tools-0.4.15-alt1.x86_64.rpm A sample & test application to test what libproxy will reply
libproxy-webkit-0.4.15-alt1.x86_64.rpm Libproxy module to support webkit
libps-0.4.5-alt1.1.x86_64.rpm Library for creating PostScript files
libps-devel-0.4.5-alt1.1.x86_64.rpm Libraries, includes, etc. to develop PostScript applications
libpsl-0.20.2-alt1.x86_64.rpm C library for the Public Suffix List
libpsl-devel-0.20.2-alt1.x86_64.rpm Development files for libpsl
libpsqlodbc-10.03.0000-alt1.x86_64.rpm The official PostgreSQL ODBC Driver
libpsrp-1.4.2-alt1.x86_64.rpm PowerShell WS-Man PSRP Client for Linux
libpst-0.6.68-alt2.1.x86_64.rpm Tools for conversion of Outlook files to mailbox and other formats
libpst-devel-0.6.68-alt2.1.x86_64.rpm Development files for libpst
Advertisement
Advertisement