libqt5-gui-5.12.2-alt1.x86_64.rpm


Advertisement

Description

libqt5-gui - GUI support library for the Qt5 toolkit

Property Value
Distribution ALT Linux Sisyphus
Repository Classic x86_64
Package filename libqt5-gui-5.12.2-alt1.x86_64.rpm
Package name libqt5-gui
Package version 5.12.2
Package release alt1
Package architecture x86_64
Package type rpm
Category System/Libraries
Homepage -
License -
Maintainer -
Download size 8.30 MB
Installed size 8.30 MB
GUI support library for the Qt5 toolkit

Alternatives

Package Version Architecture Repository
libqt5-gui-5.12.2-alt1.i586.rpm 5.12.2 i586 Classic
libqt5-gui - - -

Requires

Name Value
libEGL.so.1()(64bit) -
libGL.so.1()(64bit) -
libX11.so.6()(64bit) -
libc.so.6(GLIBC_2.11)(64bit) -
libdrm.so.2()(64bit) -
libgbm.so.1()(64bit) -
libharfbuzz.so.0()(64bit) -
libjpeg.so.62()(64bit) -
libpng16.so.16()(64bit) -
libpng16.so.16(PNG16_0)(64bit) -
libqt5-eglfsdeviceintegration = 5.12.2-alt1:sisyphus+226762.700.12.1
libqt5-eglfskmssupport = 5.12.2-alt1:sisyphus+226762.700.12.1
libqt5-network = 5.12.2-alt1:sisyphus+226762.700.12.1
libqt5-xcbqpa = 5.12.2-alt1:sisyphus+226762.700.12.1
libxcb-glx.so.0()(64bit) -
libxkbcommon.so.0()(64bit) -
libz.so.1()(64bit) -
rpmlib(PayloadIsLzma) -

Provides

Name Value
libQt5Gui.so.5()(64bit) -
libQt5Gui.so.5(Qt_5)(64bit) -
libQt5Gui.so.5(Qt_5.0)(64bit) -
libQt5Gui.so.5(Qt_5.1)(64bit) -
libQt5Gui.so.5(Qt_5.10)(64bit) -
libQt5Gui.so.5(Qt_5.11)(64bit) -
libQt5Gui.so.5(Qt_5.12)(64bit) -
libQt5Gui.so.5(Qt_5.2)(64bit) -
libQt5Gui.so.5(Qt_5.3)(64bit) -
libQt5Gui.so.5(Qt_5.4)(64bit) -
libQt5Gui.so.5(Qt_5.5)(64bit) -
libQt5Gui.so.5(Qt_5.6)(64bit) -
libQt5Gui.so.5(Qt_5.7)(64bit) -
libQt5Gui.so.5(Qt_5.8)(64bit) -
libQt5Gui.so.5(Qt_5.9)(64bit) -
libQt5Gui.so.5(Qt_5_PRIVATE_API)(64bit) -
libqt5-gui = 5.12.2-alt1:sisyphus+226762.700.12.1

Download

Type URL
Mirror ftp.altlinux.org
Binary Package libqt5-gui-5.12.2-alt1.x86_64.rpm
Source Package qt5-base-5.12.2-alt1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus x86_64 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install libqt5-gui rpm package:
    # sudo apt-get install libqt5-gui

Files

Path
/usr/lib64/libQt5Gui.so.5
/usr/lib64/libQt5Gui.so.5.12
/usr/lib64/libQt5Gui.so.5.12.2
/usr/lib64/qt5/plugins/egldeviceintegrations/libqeglfs-emu-integration.so
/usr/lib64/qt5/plugins/egldeviceintegrations/libqeglfs-kms-egldevice-integration.so
/usr/lib64/qt5/plugins/egldeviceintegrations/libqeglfs-kms-integration.so
/usr/lib64/qt5/plugins/egldeviceintegrations/libqeglfs-x11-integration.so
/usr/lib64/qt5/plugins/generic/libqevdevkeyboardplugin.so
/usr/lib64/qt5/plugins/generic/libqevdevmouseplugin.so
/usr/lib64/qt5/plugins/generic/libqevdevtabletplugin.so
/usr/lib64/qt5/plugins/generic/libqevdevtouchplugin.so
/usr/lib64/qt5/plugins/generic/libqlibinputplugin.so
/usr/lib64/qt5/plugins/generic/libqtslibplugin.so
/usr/lib64/qt5/plugins/generic/libqtuiotouchplugin.so
/usr/lib64/qt5/plugins/imageformats/libqgif.so
/usr/lib64/qt5/plugins/imageformats/libqico.so
/usr/lib64/qt5/plugins/imageformats/libqjpeg.so
/usr/lib64/qt5/plugins/platforminputcontexts/libcomposeplatforminputcontextplugin.so
/usr/lib64/qt5/plugins/platforminputcontexts/libibusplatforminputcontextplugin.so
/usr/lib64/qt5/plugins/platforms/libqeglfs.so
/usr/lib64/qt5/plugins/platforms/libqlinuxfb.so
/usr/lib64/qt5/plugins/platforms/libqminimal.so
/usr/lib64/qt5/plugins/platforms/libqminimalegl.so
/usr/lib64/qt5/plugins/platforms/libqoffscreen.so
/usr/lib64/qt5/plugins/platforms/libqvnc.so
/usr/lib64/qt5/plugins/platforms/libqxcb.so
/usr/lib64/qt5/plugins/platformthemes/libqgtk3.so
/usr/lib64/qt5/plugins/platformthemes/libqxdgdesktopportal.so
/usr/lib64/qt5/plugins/xcbglintegrations/libqxcb-egl-integration.so
/usr/lib64/qt5/plugins/xcbglintegrations/libqxcb-glx-integration.so

Changelog

2019-03-04 - Sergey V Turchin <zerg@altlinux.org> 5.12.2-alt1
- new version
2019-03-04 - Sergey V Turchin <zerg@altlinux.org> 5.11.3-alt3
- build with new libmysqlclient
2019-02-07 - Sergey V Turchin <zerg@altlinux.org> 5.11.3-alt2
- package examples
2018-12-13 - Sergey V Turchin <zerg@altlinux.org> 5.11.3-alt1
- new version
2018-10-24 - Sergey V Turchin <zerg@altlinux.org> 5.11.2-alt3
- rebuild with new icu
2018-10-03 - Aleksei Nikiforov <darktemplar@altlinux.org> 5.11.2-alt2
- NMU: fixed debuginfo generation.
2018-09-24 - Sergey V Turchin <zerg@altlinux.org> 5.11.2-alt1
- new version
2018-08-29 - Sergey V Turchin <zerg@altlinux.org> 5.11.1-alt3
- link with openssl
2018-08-16 - Sergey V Turchin <zerg@altlinux.org> 5.11.1-alt2
- build docs
2018-08-03 - Sergey V Turchin <zerg@altlinux.org> 5.11.1-alt1
- new version

See Also

Package Description
libqt5-help-5.12.2-alt1.x86_64.rpm Qt5 library
libqt5-hunspellinputmethod-5.12.2-alt1.x86_64.rpm Qt5 library
libqt5-location-5.12.2-alt1.x86_64.rpm Qt5 library
libqt5-multimedia-5.12.2-alt1.x86_64.rpm Qt5 library
libqt5-network-5.12.2-alt1.x86_64.rpm Network support library for the Qt5 toolkit
libqt5-networkauth-5.12.2-alt1.x86_64.rpm Qt5 - library
libqt5-nfc-5.12.2-alt1.x86_64.rpm Qt5 library
libqt5-opengl-5.12.2-alt1.x86_64.rpm OpenGL support library for the Qt5 toolkit
libqt5-positioning-5.12.2-alt1.x86_64.rpm Qt5 library
libqt5-positioningquick-5.12.2-alt1.x86_64.rpm Qt5 library
libqt5-printsupport-5.12.2-alt1.x86_64.rpm Printing support library for the Qt5 toolkit
libqt5-qml-5.12.2-alt1.x86_64.rpm Qt5 - library
libqt5-quick-5.12.2-alt1.x86_64.rpm Qt5 - library
libqt5-quickcontrols2-5.12.2-alt1.x86_64.rpm Qt5 library
libqt5-quickparticles-5.12.2-alt1.x86_64.rpm Qt5 - library
Advertisement
Advertisement