libqtelegram-1.0.0-alt1.x86_64.rpm


Advertisement

Description

libqtelegram - This is a Qt asynchronous library to be used as Telegram client

Property Value
Distribution ALT Linux Sisyphus
Repository Classic x86_64
Package name libqtelegram
Package version 1.0.0
Package release alt1
Package architecture x86_64
Package type rpm
Installed size 5.29 MB
Download size 5.29 MB
Official Mirror ftp.altlinux.org
This is a Qt asynchronous library to be used as Telegram client. It was
based originally on telegram-cli code (https://github.com/vysheng/tg),
but it's now completely different. Now works using signal-slot mechanism
and has an external easy to use API for client applications to interact to.

Alternatives

Package Version Architecture Repository
libqtelegram-1.0.0-alt1.i586.rpm 1.0.0 i586 Classic
libqtelegram - - -

Requires

Name Value
libQt5Core.so.5()(64bit) -
libQt5Core.so.5(Qt_5)(64bit) -
libQt5Core.so.5(Qt_5.7)(64bit) -
libQt5Gui.so.5()(64bit) -
libQt5Gui.so.5(Qt_5)(64bit) -
libQt5Network.so.5()(64bit) -
libQt5Network.so.5(Qt_5)(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libc.so.6(GLIBC_2.17)(64bit) -
libc.so.6(GLIBC_2.2.5)(64bit) -
libc.so.6(GLIBC_2.4)(64bit) -
libcrypto.so.10()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.14)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.21)(64bit) -
libz.so.1()(64bit) -
rpmlib(PayloadIsLzma) -
rpmlib(SetVersions) -
rtld(GNU_HASH) -
rtld(GNU_UNIQUE) -

Provides

Name Value
libqtelegram = 1:1.0.0-alt1
libqtelegram-ae.so.1()(64bit) -

Download

Type URL
Binary Package libqtelegram-1.0.0-alt1.x86_64.rpm
Source Package libqtelegram-1.0.0-alt1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus x86_64 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install libqtelegram rpm package:
    # sudo apt-get install libqtelegram

Files

Path
/usr/lib64/libqtelegram-ae.so.1
/usr/lib64/libqtelegram-ae.so.1.0
/usr/lib64/libqtelegram-ae.so.1.0.0
/usr/share/doc/libqtelegram-1.0.0/README
/usr/share/doc/libqtelegram-1.0.0/README.md

Changelog

2017-04-24 - Hihin Ruslan <ruslandh@altlinux.ru> 1:1.0.0-alt1
- Add pkgconfigdir/*
2017-04-20 - Hihin Ruslan <ruslandh@altlinux.ru> 10.0.0-alt1
-  initial build for ALT Linux Sisyphus

See Also

Package Description
libqtelegram-devel-1.0.0-alt1.x86_64.rpm Development files for libqtelegram
libqtermwidget-0.9.0-alt1.x86_64.rpm unicode-enabled, embeddable Qt5 terminal widget library
libqtermwidget-devel-0.9.0-alt1.x86_64.rpm unicode-enabled, embeddable Qt5 terminal widget library
libqtermwidget-qt5-0.7.1-alt1.x86_64.rpm unicode-enabled, embeddable QT4 terminal widget library
libqtermwidget-qt5-devel-0.7.1-alt1.x86_64.rpm unicode-enabled, embeddable QT4 terminal widget library
libqtexengine-0.3-alt2.x86_64.rpm Shared library of QTeXEngine
libqtexengine-devel-0.3-alt2.x86_64.rpm Development files of QTeXEngine
libqtkeychain-devel-0.9.0-alt2.S1.x86_64.rpm QtKeychain devel files
libqtkeychain-qt5-devel-0.9.0-alt2.S1.x86_64.rpm Development files for libqtkeychain-qt5
libqtkeychain1-0.9.0-alt2.S1.x86_64.rpm A password store library
libqtmimetypes-1.0.1-alt1.x86_64.rpm MIME type library for Qt4
libqtmimetypes-devel-1.0.1-alt1.x86_64.rpm Development headers for QtMimeTypes library
libqtruby4-4.14.0-alt4.4.x86_64.rpm ruby-qt4 library
libqtsingleapplication-2.6.1-alt2.x86_64.rpm The QtSingleApplication component provides support for applications that can be only started once per user
libqtsingleapplication-devel-2.6.1-alt2.x86_64.rpm The QtSingleApplication component provides support for applications that can be only started once per user
Advertisement
Advertisement