libqtsingleapplication-2.6.1-alt2.x86_64.rpm


Advertisement

Description

libqtsingleapplication - The QtSingleApplication component provides support for applications that can be only started once per user

Property Value
Distribution ALT Linux Sisyphus
Repository Classic x86_64
Package name libqtsingleapplication
Package version 2.6.1
Package release alt2
Package architecture x86_64
Package type rpm
Installed size 43.01 KB
Download size 43.01 KB
Official Mirror ftp.altlinux.org
For some applications it is useful or even critical that they are started
only once by any user. Future attempts to start the application should
activate any already running instance, and possibly perform requested
actions, e.g. loading a file, in that instance.
The QtSingleApplication class provides an interface to detect a running
instance, and to send command strings to that instance.
For console (non-GUI) applications, the QtSingleCoreApplication variant is provided, which avoids dependency on QtGui.
Authors:
--------
Nokia

Alternatives

Package Version Architecture Repository
libqtsingleapplication-2.6.1-alt2.i586.rpm 2.6.1 i586 Classic
libqtsingleapplication - - -

Requires

Name Value
libQtCore.so.4()(64bit) -
libQtGui.so.4()(64bit) -
libQtNetwork.so.4()(64bit) -
libc.so.6(GLIBC_2.2.5)(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
rpmlib(PayloadIsLzma) -
rpmlib(SetVersions) -
rtld(GNU_HASH) -

Provides

Name Value
libQtSolutions_SingleApplication-2.6.so.1()(64bit) -
libqtsingleapplication = 2.6.1-alt2

Download

Type URL
Binary Package libqtsingleapplication-2.6.1-alt2.x86_64.rpm
Source Package libqtsingleapplication-2.6.1-alt2.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus x86_64 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install libqtsingleapplication rpm package:
    # sudo apt-get install libqtsingleapplication

Files

Path
/usr/lib64/libQtSolutions_SingleApplication-2.6.so.1
/usr/lib64/libQtSolutions_SingleApplication-2.6.so.1.0
/usr/lib64/libQtSolutions_SingleApplication-2.6.so.1.0.0

Changelog

2013-05-14 - Motsyo Gennadi <drool@altlinux.ru> 2.6.1-alt2
- fix build for Sisyphus
2013-05-14 - Motsyo Gennadi <drool@altlinux.ru> 2.6.1-alt1
- initial build for ALT Linux from OpenSUSE package

See Also

Package Description
libqtsingleapplication-devel-2.6.1-alt2.x86_64.rpm The QtSingleApplication component provides support for applications that can be only started once per user
libqtsoap-2.7-alt2.S1.x86_64.rpm The Simple Object Access Protocol Qt-based client side library
libqtsoap5-2.7-alt2.S1.x86_64.rpm The Simple Object Access Protocol Qt5-based client side library
libqtspell-qt4-0.8.4-alt1.x86_64.rpm Spell checking for Qt4 text widgets
libqtspell-qt4-devel-0.8.4-alt1.x86_64.rpm Development files for libqtspell-qt4
libqtspell-qt5-0.8.4-alt1.x86_64.rpm Spell checking for Qt5 text widgets
libqtspell-qt5-devel-0.8.4-alt1.x86_64.rpm Development files for libqtspell-qt5
libqtxdg-3.2.0-alt1.x86_64.rpm Qt implementation of freedesktop.org xdg specs
libqtxdg-devel-3.2.0-alt1.x86_64.rpm Development headers for QtXdg library
libquadmath-devel-7-alt6.x86_64.rpm Dependency package for libquadmath-devel
libquadmath0-7.3.1-alt4.x86_64.rpm GCC __float128 shared support library
libquadmath4.6-devel-4.6.3-alt13.x86_64.rpm GCC __float128 support files
libquadmath4.6-devel-static-4.6.3-alt13.x86_64.rpm GCC __float128 static support library
libquadmath4.7-devel-4.7.2-alt12.x86_64.rpm GCC __float128 support files
libquadmath4.7-devel-static-4.7.2-alt12.x86_64.rpm GCC __float128 static support library
Advertisement
Advertisement