libqxmpp-qt5-0.9.3-alt1.x86_64.rpm


Advertisement

Description

libqxmpp-qt5 - Qt XMPP library

Property Value
Distribution ALT Linux Sisyphus
Repository Classic x86_64
Package name libqxmpp-qt5
Package version 0.9.3
Package release alt1
Package architecture x86_64
Package type rpm
Installed size 1.59 MB
Download size 1.59 MB
Official Mirror ftp.altlinux.org
QXmpp is a cross-platform C++ XMPP client library. It is based on Qt and
C++. This package's the fork of QXmpp for Leechcraft Internet Client.
QXmpp is pretty intuitive and easy to use. It uses Qt extensively. Qt
is the only third party library it is dependent on. Users need to a
have working knowledge of C++ and Qt basics (Signals and Slots and Qt
data types). The underlying TCP socket and the XMPP RFCs (RFC3920 and
RFC3921) have been encapsulated into classes and functions. Therefore
the user would not be bothered with these details. But it is always
recommended to the advanced users to read and enjoy the low level
details.

Alternatives

Package Version Architecture Repository
libqxmpp-qt5-0.9.3-alt1.i586.rpm 0.9.3 i586 Classic
libqxmpp-qt5 - - -

Requires

Name Value
libQt5Core.so.5()(64bit) -
libQt5Core.so.5(Qt_5)(64bit) -
libQt5Core.so.5(Qt_5.6)(64bit) -
libQt5Network.so.5()(64bit) -
libQt5Network.so.5(Qt_5)(64bit) -
libQt5Xml.so.5()(64bit) -
libQt5Xml.so.5(Qt_5)(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libc.so.6(GLIBC_2.2.5)(64bit) -
libc.so.6(GLIBC_2.4)(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libspeex.so.1()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.11)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.9)(64bit) -
libtheoradec.so.1()(64bit) -
libtheoradec.so.1(libtheoradec_1.0)(64bit) -
libtheoraenc.so.1()(64bit) -
libtheoraenc.so.1(libtheoraenc_1.0)(64bit) -
libvpx.so.3()(64bit) -
rpmlib(PayloadIsLzma) -
rpmlib(SetVersions) -
rtld(GNU_HASH) -
rtld(GNU_UNIQUE) -

Provides

Name Value
libqxmpp-qt5 = 0.9.3-alt1
libqxmpp.so.0()(64bit) -

Download

Type URL
Binary Package libqxmpp-qt5-0.9.3-alt1.x86_64.rpm
Source Package qxmpp-qt5-0.9.3-alt1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus x86_64 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install libqxmpp-qt5 rpm package:
    # sudo apt-get install libqxmpp-qt5

Files

Path
/usr/lib64/libqxmpp.so.0
/usr/lib64/libqxmpp.so.0.9
/usr/lib64/libqxmpp.so.0.9.3

Changelog

2015-12-26 - Yuri N. Sedunov <aris@altlinux.org> 0.9.3-alt1
- 0.9.3
2015-09-02 - Yuri N. Sedunov <aris@altlinux.org> 0.9.1-alt1
- 0.9.1
2015-04-18 - Yuri N. Sedunov <aris@altlinux.org> 0.8.3-alt1
- 0.8.3
2014-01-06 - Yuri N. Sedunov <aris@altlinux.org> 0.7.6-alt1
- 0.7.6
2011-07-27 - Ivan A. Melnikov <iv@altlinux.org> 0.3.45.1-alt1.git4c91ebf
- initial build for ALT Linux Sisyphus

See Also

Package Description
libqxmpp-qt5-devel-0.9.3-alt1.x86_64.rpm Qt XMPP library development files
libqxp-0.0.1-alt2.x86_64.rpm Library for import of QuarkXPress documents
libqxp-devel-0.0.1-alt2.x86_64.rpm Development files for libqxp
libqxp-tools-0.0.1-alt2.x86_64.rpm Tools to transform QuarkXPress documents into other formats
libqzeitgeist-0.8.0-alt1.x86_64.rpm Qt Zeitgeist Library
libqzeitgeist-devel-0.8.0-alt1.x86_64.rpm Development files for libqzeitgeist
librabbitmq-c-0.5.2-alt1.git20140830.1.x86_64.rpm This is a C-language AMQP client library for use with AMQP servers speaking protocol versions 0-9-1
librabbitmq-c-devel-0.5.2-alt1.git20140830.1.x86_64.rpm Development files for librabbitmq-c
libracket-6.10.1-alt1.x86_64.rpm Shared libraries of Racket
libracket-devel-6.10.1-alt1.x86_64.rpm Development files of Racket
libradial-0.1.2-alt3.git20120523.1.1.x86_64.rpm Radial library of scikits.scattpy
libradial-devel-0.1.2-alt3.git20120523.1.1.x86_64.rpm Development files of libradial
libradiusclient-ng-0.5.6-alt1.x86_64.rpm RADIUS client shared library
libradiusclient-ng-devel-0.5.6-alt1.x86_64.rpm RADIUS client development library
librados2-12.2.8-alt1.S1.x86_64.rpm RADOS distributed object store client library
Advertisement
Advertisement