libsmi-0.4.8-alt2.2.x86_64.rpm


Advertisement

Description

libsmi - A library to access SMI MIB information

Property Value
Distribution ALT Linux Sisyphus
Repository Classic x86_64
Package name libsmi
Package version 0.4.8
Package release alt2.2
Package architecture x86_64
Package type rpm
Installed size 569.10 KB
Download size 569.10 KB
Official Mirror ftp.altlinux.org
Libsmi is a C library to access MIB module information through
a well defined API that hides the nasty details of locating
and parsing SMIv1/v2 MIB modules.
This package contains tools to check, dump, and convert MIB
definitions and a steadily maintained and revised archive
of all IETF and IANA maintained standard MIB modules.

Alternatives

Package Version Architecture Repository
libsmi-0.4.8-alt2.2.i586.rpm 0.4.8 i586 Classic
libsmi - - -

Requires

Name Value
libc.so.6(GLIBC_2.14)(64bit) -
libc.so.6(GLIBC_2.2.5)(64bit) -
libc.so.6(GLIBC_2.3)(64bit) -
libc.so.6(GLIBC_2.3.4)(64bit) -
libc.so.6(GLIBC_2.4)(64bit) -
rpmlib(PayloadIsLzma) -
rtld(GNU_HASH) -
snmp-mibs -

Provides

Name Value
libsmi = 0.4.8-alt2.2
libsmi.so.2()(64bit) -

Download

Type URL
Binary Package libsmi-0.4.8-alt2.2.x86_64.rpm
Source Package libsmi-0.4.8-alt2.2.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus x86_64 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install libsmi rpm package:
    # sudo apt-get install libsmi

Files

Path
/etc/smi.conf
/usr/lib64/libsmi.so.2
/usr/lib64/libsmi.so.2.0.27
/usr/share/doc/libsmi-0.4.8/ANNOUNCE
/usr/share/doc/libsmi-0.4.8/COPYING
/usr/share/doc/libsmi-0.4.8/ChangeLog
/usr/share/doc/libsmi-0.4.8/README
/usr/share/doc/libsmi-0.4.8/THANKS
/usr/share/doc/libsmi-0.4.8/smi.conf-example

Changelog

2017-07-31 - Aleksei Nikiforov <darktemplar@altlinux.org> 0.4.8-alt2.2
- Fixed build.
2012-12-06 - Eugeny A. Rostovtsev (REAL) <real at altlinux.org> 0.4.8-alt2.1
- Fixed build
2010-10-25 - Alexey Shabalin <shaba@altlinux.ru> 0.4.8-alt2
- some backports
- security fix: CVE-2010-2891 (ALT #24394)
2010-02-25 - Alexey Shabalin <shaba@altlinux.ru> 0.4.8-alt1
- 0.4.8
- move tools to smi-tools subpackage
- move mibs to libsmi-mibs subpackage, but not build by default; use external snmp-mibs package
- disable build static by default
- add debian smistrip.patch
- change Packager
2002-11-29 - Oleg Prokopyev <riiki@altlinux.ru> 0.4.1-alt1
- new version

See Also

Package Description
libsmi-devel-0.4.8-alt2.2.x86_64.rpm Development environment for libsmi library
libsmokeakonadi4-4.11.1-alt5.x86_64.rpm Qt generic bindings library
libsmokeattica4-4.11.1-alt5.x86_64.rpm Qt generic bindings library
libsmokebase4-4.14.1-alt2.x86_64.rpm Qt generic bindings library
libsmokekate4-4.11.1-alt5.x86_64.rpm Qt generic bindings library
libsmokekdecore4-4.11.1-alt5.x86_64.rpm Qt generic bindings library
libsmokekdeui4-4.11.1-alt5.x86_64.rpm Qt generic bindings library
libsmokekfile4-4.11.1-alt5.x86_64.rpm Qt generic bindings library
libsmokekhtml4-4.11.1-alt5.x86_64.rpm KDE generic bindings library
libsmokekio4-4.11.1-alt5.x86_64.rpm Qt generic bindings library
libsmokeknewstuff24-4.11.1-alt5.x86_64.rpm Qt generic bindings library
libsmokeknewstuff34-4.11.1-alt5.x86_64.rpm Qt generic bindings library
libsmokekparts4-4.11.1-alt5.x86_64.rpm Qt generic bindings library
libsmokektexteditor4-4.11.1-alt5.x86_64.rpm KDE generic bindings library
libsmokekutils4-4.11.1-alt5.x86_64.rpm Qt generic bindings library
Advertisement
Advertisement