libstdc++6-devel-static-6.3.1-alt5.x86_64.rpm


Advertisement

Description

libstdc++6-devel-static - Static libraries for C++ development

Property Value
Distribution ALT Linux Sisyphus
Repository Classic x86_64
Package filename libstdc++6-devel-static-6.3.1-alt5.x86_64.rpm
Package name libstdc++6-devel-static
Package version 6.3.1
Package release alt5
Package architecture x86_64
Package type rpm
Category Development/C++
Homepage -
License -
Maintainer -
Download size 28.40 MB
Installed size 28.40 MB
This is the GNU implementation of the standard C++ libraries.
This package includes static library needed for C++ development.

Alternatives

Package Version Architecture Repository
libstdc++6-devel-static-6.3.1-alt5.i586.rpm 6.3.1 i586 Classic
libstdc++6-devel-static - - -

Requires

Name Value
glibc-devel-static -
libstdc++6-devel = 6.3.1-alt5:sisyphus+235475.100.3.1
rpmlib(PayloadIsLzma) -

Provides

Name Value
libstdc++6-devel-static = 6.3.1-alt5:sisyphus+235475.100.3.1

Obsoletes

Name Value
libstdc++3.0-devel-static -
libstdc++3.1-devel-static -

Download

Type URL
Mirror ftp.altlinux.org
Binary Package libstdc++6-devel-static-6.3.1-alt5.x86_64.rpm
Source Package gcc6-6.3.1-alt5.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus x86_64 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install libstdc++6-devel-static rpm package:
    # sudo apt-get install libstdc++6-devel-static

Files

Path
/etc/buildreqs/packages/substitute.d/libstdc++6-devel-static
/usr/lib64/gcc/x86_64-alt-linux/6/libstdc++.a
/usr/lib64/gcc/x86_64-alt-linux/6/libstdc++fs.a

Changelog

2019-08-05 - Gleb F-Malinovskiy <glebfm@altlinux.org> 6.3.1-alt5
- Added ppc64le support.
- Disabled gdb-plugin packaging in compat mode.
2019-04-12 - Dmitry V. Levin <ldv@altlinux.org> 6.3.1-alt4
- Fixed build with libtool 2.4.6.
2018-09-27 - Gleb F-Malinovskiy <glebfm@altlinux.org> 6.3.1-alt3.1
- Dropped redundant libcloog-isl-devel build dependency.
- doc: dropped libquadmath.info.
2018-01-10 - Gleb F-Malinovskiy <glebfm@altlinux.org> 6.3.1-alt3
- Built in gcc7 compatibility mode.
- Fixed build with glibc 2.26.
- Disabled java support.
- Dropped alternatives.
2017-02-01 - Gleb F-Malinovskiy <glebfm@altlinux.org> 6.3.1-alt2
- Updated to redhat/gcc-6-branch r244565.
- Synced with Fedora gcc 6.3.1-2.
- Fixed gnatmake's path to gcc (ALT#33003).
- Packaged buildreq substitution config for libmpx6-devel-static.
- Enabled java on aarch64.
2016-12-21 - Gleb F-Malinovskiy <glebfm@altlinux.org> 6.3.1-alt1
- Updated to redhat/gcc-6-branch r243852.
- Synced with Fedora gcc 6.3.1-1 and Debian gcc-6 6.2.0-13.
2016-11-10 - Gleb F-Malinovskiy <glebfm@altlinux.org> 5.3.1-alt4
- Updated to redhat/gcc-5-branch 234777.
2016-03-10 - Gleb F-Malinovskiy <glebfm@altlinux.org> 5.3.1-alt3
- Moved liblto_plugin.so back into %_libexecdir.
- Added executable bit to liblto_plugin.so.
- Backported upstram fix:
+ Enable frame pointer for TARGET_64BIT_MS_ABI when stack is
misaligned (ALT#31834).
2016-02-24 - Gleb F-Malinovskiy <glebfm@altlinux.org> 5.3.1-alt2
- Moved liblto_plugin.so into %_libdir.
2015-12-17 - Gleb F-Malinovskiy <glebfm@altlinux.org> 5.3.1-alt1
- Updated to redhat/gcc-5-branch 231358.
- Synced with Fedora gcc-5.3.1-2 and Debian 5.3.1-4.
- Added patch for aarch64 linker path.
- Changed compress_method to xz.

See Also

Package Description
libstdc++7-devel-7.3.1-alt9.x86_64.rpm Header files and libraries for C++ development
libstdc++7-devel-static-7.3.1-alt9.x86_64.rpm Static libraries for C++ development
libstdc++8-devel-8.3.1-alt5.x86_64.rpm Header files and libraries for C++ development
libstdc++8-devel-static-8.3.1-alt5.x86_64.rpm Static libraries for C++ development
libstemmer-0-alt1.svn585.x86_64.rpm C stemming algorithm library
libstemmer-devel-0-alt1.svn585.x86_64.rpm libstemmer development libraries and includes
libstfl0-0.24-alt5.2.x86_64.rpm library which implements a curses-based widget set for text terminals
libstfl0-devel-0.24-alt5.2.x86_64.rpm Headers for libstfl0
libstk-4.5.0-alt1.1.x86_64.rpm C++ classes for audio digital signal processing
libstk-devel-4.5.0-alt1.1.x86_64.rpm Header files for LibSTK library
libstk-devel-static-4.5.0-alt1.1.x86_64.rpm Static LibSTK library
libstlink-2018.04.18-alt2.qa1.x86_64.rpm Shared library of stlink
libstlink-devel-2018.04.18-alt2.qa1.x86_64.rpm Development files of stlink
libstoken-0.92-alt1.x86_64.rpm stoken library
libstoken-devel-0.92-alt1.x86_64.rpm Header files and library for development with stoken
Advertisement
Advertisement