libtsan4.9-devel-static-4.9.2-alt7.x86_64.rpm


Advertisement

Description

libtsan4.9-devel-static - The Thread Sanitizer static library

Property Value
Distribution ALT Linux Sisyphus
Repository Classic x86_64
Package filename libtsan4.9-devel-static-4.9.2-alt7.x86_64.rpm
Package name libtsan4.9-devel-static
Package version 4.9.2
Package release alt7
Package architecture x86_64
Package type rpm
Category Development/C
Homepage -
License -
Maintainer -
Download size 6.26 MB
Installed size 6.26 MB
This package contains Thread Sanitizer static library.

Alternatives

Package Version Architecture Repository
libtsan4.9-devel-static - - -

Requires

Name Value
glibc-devel-static -
libtsan0 >= 4.9.2-alt7
rpmlib(PayloadIsLzma) -

Provides

Name Value
libtsan4.9-devel-static = 4.9.2-alt7:sisyphus+235519.200.2.1

Download

Type URL
Mirror ftp.altlinux.org
Binary Package libtsan4.9-devel-static-4.9.2-alt7.x86_64.rpm
Source Package gcc4.9-4.9.2-alt7.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus x86_64 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install libtsan4.9-devel-static rpm package:
    # sudo apt-get install libtsan4.9-devel-static

Files

Path
/etc/buildreqs/packages/substitute.d/libtsan4.9-devel-static
/usr/lib64/gcc/x86_64-alt-linux/4.9/libtsan.a

Changelog

2019-08-06 - Gleb F-Malinovskiy <glebfm@altlinux.org> 4.9.2-alt7
- Added ppc64le support.
- Fixed build with libtool 2.4.6 (ldv@).
- doc: dropped libquadmath.info.
2018-09-29 - Gleb F-Malinovskiy <glebfm@altlinux.org> 4.9.2-alt6.1
- Dropped redundant libcloog-isl-devel build dependency.
- Exclude aarch64 architecture.
2018-01-12 - Gleb F-Malinovskiy <glebfm@altlinux.org> 4.9.2-alt6
- Rebuilt with gcc 4.9.
- Fixed build with glibc 2.26.
- Disabled java support.
- Dropped alternatives.
2016-02-01 - Gleb F-Malinovskiy <glebfm@altlinux.org> 4.9.2-alt5
- Changed compress_method to xz.
2015-05-15 - Gleb F-Malinovskiy <glebfm@altlinux.org> 4.9.2-alt4
- Built in gcc5 compatibility mode.
- Fixed gcc -dumpversion output.
2015-03-18 - Gleb F-Malinovskiy <glebfm@altlinux.org> 4.9.2-alt3
- Turned on -Wtrampolines by default.
2015-03-17 - Gleb F-Malinovskiy <glebfm@altlinux.org> 4.9.2-alt2
- Updated to redhat/gcc-4_9-branch r220644.
- Synced with Fedora gcc-4.9.2-6 and Debian 4.9.2-10.
- Dropped Linaro patch.
2014-11-13 - Gleb F-Malinovskiy <glebfm@altlinux.org> 4.9.2-alt1
- Updated to redhat/gcc-4_9-branch r216995.
- Synced with Fedora gcc-4.9.2-1.
2014-10-27 - Gleb F-Malinovskiy <glebfm@altlinux.org> 4.9.1-alt2
- Updated to redhat/gcc-4_9-branch r216625.
- Synced with Fedora gcc-4.9.1-13.
- Fixed base version.
2014-09-22 - Gleb F-Malinovskiy <glebfm@altlinux.org> 4.9.1-alt1
- Updated to redhat/gcc-4_9-branch r215456.
- Synced with Fedora gcc-4.9.1-10 and Debian 4.9.1-15.

See Also

Package Description
libtsan5-devel-static-5.3.1-alt7.x86_64.rpm The Thread Sanitizer static library
libtsan6-devel-static-6.3.1-alt5.x86_64.rpm The Thread Sanitizer static library
libtsan7-devel-static-7.3.1-alt9.x86_64.rpm The Thread Sanitizer static library
libtsan8-devel-static-8.3.1-alt5.x86_64.rpm The Thread Sanitizer static library
libtsk-4.6.7-alt2.x86_64.rpm libraries for developing applications which will use libtsk
libtsk-devel-4.6.7-alt2.x86_64.rpm Header files and libraries for developing applications which will use libtsk
libtsm-4.0.1-alt1.x86_64.rpm Terminal-emulator State Machine
libtsm-devel-4.0.1-alt1.x86_64.rpm Development files for libtsm
libtsmux-0.2.0-alt1.1.qa1.x86_64.rpm Library for muxing of MPEG Transport Streams
libtsmux-devel-0.2.0-alt1.1.qa1.x86_64.rpm Libraries and includefiles for libtsmux
libtumbler-0.2.7-alt1.x86_64.rpm A D-bus thumbnailing framweork
libtumbler-devel-0.2.7-alt1.x86_64.rpm Development files for tumbler
libtunepimp-0.5.3-alt5.1.1.x86_64.rpm Library that provides access to the MusicBrainz server
libtunepimp-devel-0.5.3-alt5.1.1.x86_64.rpm Include Files and Libraries mandatory for Development
libturbojpeg-2.0.2-alt1.x86_64.rpm A turbojpeg library
Advertisement
Advertisement