lightdm-devel-1.30.0-alt6.x86_64.rpm


Advertisement

Description

lightdm-devel - Development Files for LightDM

Property Value
Distribution ALT Linux Sisyphus
Repository Classic x86_64
Package filename lightdm-devel-1.30.0-alt6.x86_64.rpm
Package name lightdm-devel
Package version 1.30.0
Package release alt6
Package architecture x86_64
Package type rpm
Category Development/C
Homepage -
License -
Maintainer -
Download size 48.55 KB
Installed size 48.55 KB
This package provides all necessary files for developing plugins, greeters, and
additional interface libraries for LightDM.

Alternatives

Package Version Architecture Repository
lightdm-devel-1.30.0-alt6.i586.rpm 1.30.0 i586 Classic
lightdm-devel - - -

Requires

Name Value
/usr/lib64/pkgconfig -
/usr/share/vala/vapi -
glib2-devel -
libgio-devel -
liblightdm-qt = 1.30.0-alt6:sisyphus+235252.300.4.1
liblightdm-qt5 = 1.30.0-alt6:sisyphus+235252.300.4.1
libqt4-devel -
lightdm = 1.30.0-alt6:sisyphus+235252.300.4.1
pkgconfig(Qt5Core) -
pkgconfig(Qt5Gui) -
pkgconfig(QtCore) -
pkgconfig(QtGui) -
rpmlib(PayloadIsLzma) -
vapi(gio-2.0) -
vapi(posix) -

Provides

Name Value
lightdm-devel = 1.30.0-alt6:sisyphus+235252.300.4.1
pkgconfig(liblightdm-gobject-1) = 1.30.0
pkgconfig(liblightdm-qt-3) = 1.30.0
pkgconfig(liblightdm-qt5-3) = 1.30.0
vapi(liblightdm-gobject-1) -

Download

Type URL
Mirror ftp.altlinux.org
Binary Package lightdm-devel-1.30.0-alt6.x86_64.rpm
Source Package lightdm-1.30.0-alt6.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus x86_64 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install lightdm-devel rpm package:
    # sudo apt-get install lightdm-devel

Files

Path
/usr/include/lightdm-gobject-1/lightdm.h
/usr/include/lightdm-gobject-1/lightdm/greeter.h
/usr/include/lightdm-gobject-1/lightdm/language.h
/usr/include/lightdm-gobject-1/lightdm/layout.h
/usr/include/lightdm-gobject-1/lightdm/power.h
/usr/include/lightdm-gobject-1/lightdm/session.h
/usr/include/lightdm-gobject-1/lightdm/system.h
/usr/include/lightdm-gobject-1/lightdm/user.h
/usr/include/lightdm-qt-3/
/usr/include/lightdm-qt-3/QLightDM/Greeter
/usr/include/lightdm-qt-3/QLightDM/Power
/usr/include/lightdm-qt-3/QLightDM/SessionsModel
/usr/include/lightdm-qt-3/QLightDM/UsersModel
/usr/include/lightdm-qt-3/QLightDM/greeter.h
/usr/include/lightdm-qt-3/QLightDM/power.h
/usr/include/lightdm-qt-3/QLightDM/sessionsmodel.h
/usr/include/lightdm-qt-3/QLightDM/usersmodel.h
/usr/include/lightdm-qt5-3/
/usr/include/lightdm-qt5-3/QLightDM/Greeter
/usr/include/lightdm-qt5-3/QLightDM/Power
/usr/include/lightdm-qt5-3/QLightDM/SessionsModel
/usr/include/lightdm-qt5-3/QLightDM/UsersModel
/usr/include/lightdm-qt5-3/QLightDM/greeter.h
/usr/include/lightdm-qt5-3/QLightDM/power.h
/usr/include/lightdm-qt5-3/QLightDM/sessionsmodel.h
/usr/include/lightdm-qt5-3/QLightDM/usersmodel.h
/usr/lib64/liblightdm-gobject-1.so
/usr/lib64/liblightdm-qt-3.so
/usr/lib64/liblightdm-qt5-3.so
/usr/lib64/pkgconfig/liblightdm-gobject-1.pc
/usr/lib64/pkgconfig/liblightdm-qt-3.pc
/usr/lib64/pkgconfig/liblightdm-qt5-3.pc
/usr/share/vala/vapi/liblightdm-gobject-1.deps
/usr/share/vala/vapi/liblightdm-gobject-1.vapi

Changelog

2019-08-12 - Paul Wolneykien <manowar@altlinux.org> 1.30.0-alt6
- Use the first available session config as default.
2019-08-06 - Paul Wolneykien <manowar@altlinux.org> 1.30.0-alt5
- Don't configure "default" user session explicitly.
2019-08-02 - Paul Wolneykien <manowar@altlinux.org> 1.30.0-alt4
- Fix: Don't try to own extra files in /etc/X11.
- Fix: get rid of the extra xinitrc dependency.
2019-07-31 - Paul Wolneykien <manowar@altlinux.org> 1.30.0-alt3
- Use a greeter startup wrapper script with keyboard setup (closes:
2019-05-23 - Valery Inozemtsev <shrek@altlinux.ru> 1.30.0-alt2
- remove wayland session support form lightdm.conf
2019-05-17 - Valery Inozemtsev <shrek@altlinux.ru> 1.30.0-alt1
- 1.30.0
2019-05-15 - Valery Inozemtsev <shrek@altlinux.ru> 1.28.0-alt1
- 1.28.0
2019-01-15 - Ivan A. Melnikov <iv@altlinux.org> 1.16.7-alt24
- Replace 'Conflicts <>' with auxiliary package
2019-01-14 - Ivan A. Melnikov <iv@altlinux.org> 1.16.7-alt23
- Remove MEMLOCK limit in systemd unit file (closes: #35844).
2018-08-04 - Fr. Br. George <george@altlinux.ru> 1.16.7-alt22
- Fix lightdm-greeter-hide-users typo

See Also

Package Description
lightdm-gir-1.30.0-alt6.x86_64.rpm GObject introspection data for the lightdm
lightdm-gtk-greeter-2.0.1-alt15.x86_64.rpm LightDM GTK+ Greeter
lightdm-kde-greeter-0.3.2.1-alt3.x86_64.rpm LightDM KDE4 Greeter
lightdm-qt-greeter-1.1.1-alt3.x86_64.rpm LightDM QT Greeter
lightlang-0.8.6.s-alt1.qa3.x86_64.rpm Dictionary Shell on Qt4
lightmediascanner-0.5.2-alt1.x86_64.rpm Light Media Scanner
lighttpd-1.4.54-alt1.x86_64.rpm A fast webserver with minimal memory-footprint
lighttpd-auth-gssapi-1.4.54-alt1.x86_64.rpm GSSAPI authentication for lighttpd
lighttpd-auth-ldap-1.4.54-alt1.x86_64.rpm LDAP authentication for lighttpd
lighttpd-auth-mysql-1.4.54-alt1.x86_64.rpm MySQL authentication for lighttpd
lighttpd-cml-1.4.54-alt1.x86_64.rpm CML (Cache Meta Language) lighttpd module
lighttpd-ldap-vhost-1.4.54-alt1.x86_64.rpm LDAP based vhosting lighttpd module
lighttpd-mysql-vhost-1.4.54-alt1.x86_64.rpm MySQL based vhosting lighttpd module
lighttpd-pgsql-vhost-1.4.54-alt1.x86_64.rpm PostgreSQL based vhosting lighttpd module
lighttpd-rrdtool-1.4.54-alt1.x86_64.rpm rrdtool support lighttpd module
Advertisement
Advertisement