opensc-0.19.0-alt4.x86_64.rpm


Advertisement

Description

opensc - OpenSC library - for accessing SmartCard devices using PC/SC Lite

Property Value
Distribution ALT Linux Sisyphus
Repository Classic x86_64
Package filename opensc-0.19.0-alt4.x86_64.rpm
Package name opensc
Package version 0.19.0
Package release alt4
Package architecture x86_64
Package type rpm
Category System/Configuration/Hardware
Homepage -
License -
Maintainer -
Download size 923.57 KB
Installed size 923.57 KB
libopensc is a library for accessing SmartCard devices using PC/SC
Lite middleware package. It is also the core library of the OpenSC
project. Basic functionality (e.g. SELECT FILE, READ BINARY) should
work on any ISO 7816-4 compatible SmartCard. Encryption and decryption
using private keys on the SmartCard is at the moment possible only
with PKCS#15 compatible cards, such as the FINEID (Finnish Electronic
IDentity) card manufactured by Setec.

Alternatives

Package Version Architecture Repository
opensc-0.19.0-alt4.i586.rpm 0.19.0 i586 Classic
opensc - - -

Requires

Name Value
/lib64/ld-linux-x86-64.so.2 -
libc.so.6(GLIBC_2.3.3)(64bit) -
libcrypto.so.1.1()(64bit) -
libopensc = 0.19.0-alt4:sisyphus+236676.100.1.1
libreadline.so.7()(64bit) -
rpmlib(PayloadIsLzma) -

Provides

Name Value
opensc = 0.19.0-alt4:sisyphus+236676.100.1.1

Download

Type URL
Mirror ftp.altlinux.org
Binary Package opensc-0.19.0-alt4.x86_64.rpm
Source Package opensc-0.19.0-alt4.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus x86_64 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install opensc rpm package:
    # sudo apt-get install opensc

Files

Path
/etc/bash_completion.d/cardos-tool
/etc/bash_completion.d/cryptoflex-tool
/etc/bash_completion.d/dnie-tool
/etc/bash_completion.d/egk-tool
/etc/bash_completion.d/eidenv
/etc/bash_completion.d/gids-tool
/etc/bash_completion.d/iasecc-tool
/etc/bash_completion.d/netkey-tool
/etc/bash_completion.d/npa-tool
/etc/bash_completion.d/openpgp-tool
/etc/bash_completion.d/opensc-asn1
/etc/bash_completion.d/opensc-explorer
/etc/bash_completion.d/opensc-notify
/etc/bash_completion.d/opensc-tool
/etc/bash_completion.d/piv-tool
/etc/bash_completion.d/pkcs11-tool
/etc/bash_completion.d/pkcs15-crypt
/etc/bash_completion.d/pkcs15-init
/etc/bash_completion.d/pkcs15-tool
/etc/bash_completion.d/sc-hsm-tool
/etc/bash_completion.d/westcos-tool
/usr/bin/cardos-tool
/usr/bin/cryptoflex-tool
/usr/bin/dnie-tool
/usr/bin/egk-tool
/usr/bin/eidenv
/usr/bin/gids-tool
/usr/bin/iasecc-tool
/usr/bin/netkey-tool
/usr/bin/npa-tool
/usr/bin/openpgp-tool
/usr/bin/opensc-asn1
/usr/bin/opensc-explorer
/usr/bin/opensc-notify
/usr/bin/opensc-tool
/usr/bin/piv-tool
/usr/bin/pkcs11-tool
/usr/bin/pkcs15-crypt
/usr/bin/pkcs15-init
/usr/bin/pkcs15-tool
/usr/bin/sc-hsm-tool
/usr/bin/westcos-tool
/usr/share/applications/org.opensc.notify.desktop
/usr/share/doc/opensc-0.19.0/NEWS
/usr/share/doc/opensc-0.19.0/README.md
/usr/share/man/man1/cardos-tool.1.xz
/usr/share/man/man1/cryptoflex-tool.1.xz
/usr/share/man/man1/dnie-tool.1.xz
/usr/share/man/man1/egk-tool.1.xz
/usr/share/man/man1/eidenv.1.xz
/usr/share/man/man1/gids-tool.1.xz
/usr/share/man/man1/iasecc-tool.1.xz
/usr/share/man/man1/netkey-tool.1.xz
/usr/share/man/man1/npa-tool.1.xz
/usr/share/man/man1/openpgp-tool.1.xz
/usr/share/man/man1/opensc-asn1.1.xz
/usr/share/man/man1/opensc-explorer.1.xz
/usr/share/man/man1/opensc-notify.1.xz
/usr/share/man/man1/opensc-tool.1.xz
/usr/share/man/man1/piv-tool.1.xz
/usr/share/man/man1/pkcs11-tool.1.xz
/usr/share/man/man1/pkcs15-crypt.1.xz
/usr/share/man/man1/pkcs15-init.1.xz
/usr/share/man/man1/pkcs15-tool.1.xz
/usr/share/man/man1/sc-hsm-tool.1.xz
/usr/share/man/man1/westcos-tool.1.xz
/usr/share/man/man5/opensc.conf.5.xz
/usr/share/man/man5/pkcs15-profile.5.xz

Changelog

2019-08-27 - Paul Wolneykien <manowar@altlinux.org> 0.19.0-alt4
- Added patch closing a small memory leak issue (fixes CVE-2019-6502).
2018-12-10 - Paul Wolneykien <manowar@altlinux.org> 0.19.0-alt3
- New release version 0.19.0.
2018-09-14 - Paul Wolneykien <manowar@altlinux.org> 0.19.0-alt2.rc1
- Workaround format-truncation error in card-gids.c using a larger
buffer (patch).
2018-09-13 - Paul Wolneykien <manowar@altlinux.org> 0.19.0-alt1.rc1
- New pre-release version 0.19.0-rc1.
- Fixed multiple security problems due to out of bound writes/reads
(Fixes: CVE-2018-16391, CVE-2018-16392, CVE-2018-16393, CVE-2018-16418,
CVE-2018-16419, CVE-2018-16420, CVE-2018-16421, CVE-2018-16422,
CVE-2018-16423, CVE-2018-16424, CVE-2018-16425, CVE-2018-16426,
CVE-2018-16427).
2018-08-29 - Grigory Ustinov <grenka@altlinux.org> 0.17.0-alt1.1
- NMU: Rebuild with new openssl 1.1.0.
2018-06-08 - Paul Wolneykien <manowar@altlinux.org> 0.18.0-alt1
- Freshed up to the upstream version 0.18.0.
- New opensc-notify desktop util.
2017-09-12 - Paul Wolneykien <manowar@altlinux.org> 0.17.0-alt1
- Fresh up to v0.17.0.
2017-06-26 - Paul Wolneykien <manowar@altlinux.org> 0.17.0-alt0.rc1
- Remove the usused patches.
- Fresh up to v0.17.0-rc1.
2016-11-09 - Dmitry Derjavin <dd@altlinux.org> 0.16.0-alt3
- opensc.conf moved to library package
- (closes: 32735)
2016-10-13 - Dmitry Derjavin <dd@altlinux.org> 0.16.0-alt2
- Reqs and configure params cleanup.

See Also

Package Description
openscad-2015.03.3-alt2_12.1.x86_64.rpm The Programmers Solid 3D CAD Modeller
openscada-0.9.0-alt6.x86_64.rpm Open SCADA system
openscada-Archive.DBArch-0.9.0-alt6.x86_64.rpm To DB archiver
openscada-Archive.FSArch-0.9.0-alt6.x86_64.rpm To file system archiver
openscada-DAQ.AMRDevs-0.9.0-alt6.x86_64.rpm AMR devices
openscada-DAQ.BFN-0.9.0-alt6.x86_64.rpm Big Farm Net
openscada-DAQ.BlockCalc-0.9.0-alt6.x86_64.rpm Block based calculator
openscada-DAQ.Comedi-0.9.0-alt6.x86_64.rpm DAQ boards by Comedi
openscada-DAQ.DAQGate-0.9.0-alt6.x86_64.rpm Data sources gate
openscada-DAQ.DCON-0.9.0-alt6.x86_64.rpm DCON client
openscada-DAQ.JavaLikeCalc-0.9.0-alt6.x86_64.rpm Java-like based calculator
openscada-DAQ.LogicLev-0.9.0-alt6.x86_64.rpm Logic level
openscada-DAQ.MMS-0.9.0-alt6.x86_64.rpm MMS(IEC-9506)
openscada-DAQ.ModBus-0.9.0-alt6.x86_64.rpm ModBus protocol and DAQ
openscada-DAQ.OPC_UA-0.9.0-alt6.x86_64.rpm OPC UA protocol and DAQ
Advertisement
Advertisement