python-module-cffi-1.10.0-alt1.1.x86_64.rpm


Advertisement

Description

python-module-cffi - Foreign Function Interface for Python calling C code

Property Value
Distribution ALT Linux Sisyphus
Repository Classic x86_64
Package filename python-module-cffi-1.10.0-alt1.1.x86_64.rpm
Package name python-module-cffi
Package version 1.10.0
Package release alt1.1
Package architecture x86_64
Package type rpm
Category Development/Python
Homepage -
License -
Maintainer -
Download size 1.01 MB
Installed size 1.01 MB
Foreign Function Interface for Python calling C code.

Alternatives

Package Version Architecture Repository
python-module-cffi-1.10.0-alt1.1.i586.rpm 1.10.0 i586 Classic
python-module-cffi - - -

Requires

Name Value
/usr/lib64/python2.7/site-packages -
ld-linux-x86-64.so.2()(64bit) -
ld-linux-x86-64.so.2(GLIBC_2.3)(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libc.so.6(GLIBC_2.2.5)(64bit) -
libc.so.6(GLIBC_2.3)(64bit) -
libc.so.6(GLIBC_2.3.4)(64bit) -
libc.so.6(GLIBC_2.4)(64bit) -
libdl.so.2(GLIBC_2.2.5)(64bit) -
libffi.so.6()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libpython2.7.so.1.0()(64bit) -
python = 2.7
python-module-pycparser -
python-modules -
python2.7(ctypes) -
rpmlib(PayloadIsLzma) -
rpmlib(SetVersions) -
rtld(GNU_HASH) -

Provides

Name Value
python-module-cffi = 1.10.0-alt1.1
python2.7(_cffi_backend) -
python2.7(cffi) -
python2.7(cffi.api) -
python2.7(cffi.backend_ctypes) -
python2.7(cffi.cffi_opcode) -
python2.7(cffi.commontypes) -
python2.7(cffi.cparser) -
python2.7(cffi.error) -
python2.7(cffi.ffiplatform) -
python2.7(cffi.lock) -
python2.7(cffi.model) -
python2.7(cffi.recompiler) -
python2.7(cffi.setuptools_ext) -
python2.7(cffi.vengine_cpy) -
python2.7(cffi.vengine_gen) -
python2.7(cffi.verifier) -
python2.7-module-cffi = 1.10.0-alt1.1

Download

Type URL
Mirror ftp.altlinux.org
Binary Package python-module-cffi-1.10.0-alt1.1.x86_64.rpm
Source Package python-module-cffi-1.10.0-alt1.1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus x86_64 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install python-module-cffi rpm package:
    # sudo apt-get install python-module-cffi

Files

Path
/usr/lib64/python2.7/site-packages/_cffi_backend.so
/usr/lib64/python2.7/site-packages/cffi/__init__.py
/usr/lib64/python2.7/site-packages/cffi/__init__.pyc
/usr/lib64/python2.7/site-packages/cffi/__init__.pyo
/usr/lib64/python2.7/site-packages/cffi/_cffi_include.h
/usr/lib64/python2.7/site-packages/cffi/_embedding.h
/usr/lib64/python2.7/site-packages/cffi/api.py
/usr/lib64/python2.7/site-packages/cffi/api.pyc
/usr/lib64/python2.7/site-packages/cffi/api.pyo
/usr/lib64/python2.7/site-packages/cffi/backend_ctypes.py
/usr/lib64/python2.7/site-packages/cffi/backend_ctypes.pyc
/usr/lib64/python2.7/site-packages/cffi/backend_ctypes.pyo
/usr/lib64/python2.7/site-packages/cffi/cffi_opcode.py
/usr/lib64/python2.7/site-packages/cffi/cffi_opcode.pyc
/usr/lib64/python2.7/site-packages/cffi/cffi_opcode.pyo
/usr/lib64/python2.7/site-packages/cffi/commontypes.py
/usr/lib64/python2.7/site-packages/cffi/commontypes.pyc
/usr/lib64/python2.7/site-packages/cffi/commontypes.pyo
/usr/lib64/python2.7/site-packages/cffi/cparser.py
/usr/lib64/python2.7/site-packages/cffi/cparser.pyc
/usr/lib64/python2.7/site-packages/cffi/cparser.pyo
/usr/lib64/python2.7/site-packages/cffi/error.py
/usr/lib64/python2.7/site-packages/cffi/error.pyc
/usr/lib64/python2.7/site-packages/cffi/error.pyo
/usr/lib64/python2.7/site-packages/cffi/ffiplatform.py
/usr/lib64/python2.7/site-packages/cffi/ffiplatform.pyc
/usr/lib64/python2.7/site-packages/cffi/ffiplatform.pyo
/usr/lib64/python2.7/site-packages/cffi/lock.py
/usr/lib64/python2.7/site-packages/cffi/lock.pyc
/usr/lib64/python2.7/site-packages/cffi/lock.pyo
/usr/lib64/python2.7/site-packages/cffi/model.py
/usr/lib64/python2.7/site-packages/cffi/model.pyc
/usr/lib64/python2.7/site-packages/cffi/model.pyo
/usr/lib64/python2.7/site-packages/cffi/parse_c_type.h
/usr/lib64/python2.7/site-packages/cffi/recompiler.py
/usr/lib64/python2.7/site-packages/cffi/recompiler.pyc
/usr/lib64/python2.7/site-packages/cffi/recompiler.pyo
/usr/lib64/python2.7/site-packages/cffi/setuptools_ext.py
/usr/lib64/python2.7/site-packages/cffi/setuptools_ext.pyc
/usr/lib64/python2.7/site-packages/cffi/setuptools_ext.pyo
/usr/lib64/python2.7/site-packages/cffi/vengine_cpy.py
/usr/lib64/python2.7/site-packages/cffi/vengine_cpy.pyc
/usr/lib64/python2.7/site-packages/cffi/vengine_cpy.pyo
/usr/lib64/python2.7/site-packages/cffi/vengine_gen.py
/usr/lib64/python2.7/site-packages/cffi/vengine_gen.pyc
/usr/lib64/python2.7/site-packages/cffi/vengine_gen.pyo
/usr/lib64/python2.7/site-packages/cffi/verifier.py
/usr/lib64/python2.7/site-packages/cffi/verifier.pyc
/usr/lib64/python2.7/site-packages/cffi/verifier.pyo
/usr/lib64/python2.7/site-packages/cffi-1.10.0-py2.7.egg-info/PKG-INFO
/usr/lib64/python2.7/site-packages/cffi-1.10.0-py2.7.egg-info/SOURCES.txt
/usr/lib64/python2.7/site-packages/cffi-1.10.0-py2.7.egg-info/dependency_links.txt
/usr/lib64/python2.7/site-packages/cffi-1.10.0-py2.7.egg-info/entry_points.txt
/usr/lib64/python2.7/site-packages/cffi-1.10.0-py2.7.egg-info/not-zip-safe
/usr/lib64/python2.7/site-packages/cffi-1.10.0-py2.7.egg-info/requires.txt
/usr/lib64/python2.7/site-packages/cffi-1.10.0-py2.7.egg-info/top_level.txt

Changelog

2018-03-22 - Aleksei Nikiforov <darktemplar@altlinux.org> 1.10.0-alt1.1
- (NMU) Rebuilt with python-3.6.4.
2017-06-08 - Vladimir Didenko <cow@altlinux.ru> 1.10.0-alt1
- Version 1.10.0
2016-03-17 - Ivan Zakharyaschev <imz@altlinux.org> 1.4.2-alt1.1
- (NMU) rebuild with python3-3.5 & rpm-build-python3-0.1.10
(for ABI dependence and new python3(*) reqs)
2016-01-10 - Vladimir Didenko <cow@altlinux.ru> 1.4.2-alt1
- Version 1.4.2
2015-08-03 - Eugeny A. Rostovtsev (REAL) <real at altlinux.org> 1.1.2-alt1
- Version 1.1.2
2014-08-04 - Lenar Shakirov <snejok@altlinux.ru> 0.8.6-alt2
- python{3,}-module-pycparser added to Requires
- Because find-requires script /usr/lib/rpm/python3.req.py says:
* cffi/cparser.py: line=2 possible relative import from ., UNIMPLEMENTED
2014-07-11 - Vitaly Lipatov <lav@altlinux.ru> 0.8.6-alt1
- new version 0.8.6 (with rpmrb script) (ALT bug #30174)
2014-07-11 - Eugeny A. Rostovtsev (REAL) <real at altlinux.org> 0.6-alt3
- Added module for Python3
2013-04-08 - Vitaly Lipatov <lav@altlinux.ru> 0.6-alt2
- fix packing
2013-04-08 - Vitaly Lipatov <lav@altlinux.ru> 0.6-alt1
- initial build for ALT Linux Sisyphus

See Also

Package Description
python-module-cgraph-20110131-alt1.1.x86_64.rpm High performance Directed Acyclic Graph implemented in Cython
python-module-chempy-1.8.6.0-alt1.x86_64.rpm Application in Python which is meant to help in learning chemistry
python-module-chewing-0.5.1-alt1_8.x86_64.rpm Python binding for libchewing
python-module-cjson-1.1.0-alt1.x86_64.rpm Fast JSON encoder/decoder for Python
python-module-clearsilver-0.10.5-alt1.2.x86_64.rpm Neotonic ClearSilver Python Module
python-module-cmemcache-0.95-alt0.2.x86_64.rpm A python module for memcached daemon
python-module-cobs-1.0.0-alt1.1.1.1.x86_64.rpm Consistent Overhead Byte Stuffing (COBS)
python-module-cobs-tests-1.0.0-alt1.1.1.1.x86_64.rpm Tests for cobs
python-module-collective-1.1.3-alt1.1.x86_64.rpm Core files of collective
python-module-collective.funkload-0.5-alt1.dev0.git20140620.1.1.x86_64.rpm Zope and Plone focussed extensions to funkload
python-module-collective.funkload-tests-0.5-alt1.dev0.git20140620.1.1.x86_64.rpm Tests for collective.funkload
python-module-collective.js-1.0.1-alt2.dev0.git20130408.1.1.x86_64.rpm Core files of collective.js
python-module-collective.js.extjs-1.3-alt1.dev0.git20130324.1.1.x86_64.rpm ExtJS integration for Plone
python-module-collective.js.jqsmartTruncation-1.0.1-alt1.dev0.git20120507.1.1.x86_64.rpm This Package provides smart truncation
python-module-collective.js.knockout-3.2.1-alt1.dev0.git20141027.1.1.x86_64.rpm knockout.js integration for Plone
Advertisement
Advertisement