python-module-sip-4.19.13-alt1.x86_64.rpm


Advertisement

Description

python-module-sip - Python bindings generator for C++ class libraries

Property Value
Distribution ALT Linux Sisyphus
Repository Classic x86_64
Package filename python-module-sip-4.19.13-alt1.x86_64.rpm
Package name python-module-sip
Package version 4.19.13
Package release alt1
Package architecture x86_64
Package type rpm
Category Development/Python
Homepage -
License -
Maintainer -
Download size 670.20 KB
Installed size 670.20 KB
Generates Python bindings for C++ class libraries from a set of class
specification files.  Also includes a Python extension module needed by all
generated bindings.

Alternatives

Package Version Architecture Repository
python-module-sip-4.19.13-alt1.i586.rpm 4.19.13 i586 Classic
python-module-sip - - -

Requires

Name Value
/lib64/ld-linux-x86-64.so.2 -
/usr/lib64/python2.7/site-packages -
libc.so.6(GLIBC_2.14)(64bit) -
libc.so.6(GLIBC_2.2.5)(64bit) -
libc.so.6(GLIBC_2.3)(64bit) -
libc.so.6(GLIBC_2.3.4)(64bit) -
libc.so.6(GLIBC_2.4)(64bit) -
python = 2.7
rpmlib(PayloadIsLzma) -
rtld(GNU_HASH) -

Provides

Name Value
python-module-sip = 4.19.13-alt1:sisyphus+220458.100.5.2
python2.7(sip) -
python2.7-module-sip = 4.19.13-alt1
sip = 4.19.13-alt1

Obsoletes

Name Value
sip <= 4.1-alt2.1

Download

Type URL
Mirror ftp.altlinux.org
Binary Package python-module-sip-4.19.13-alt1.x86_64.rpm
Source Package python-module-sip-4.19.13-alt1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus x86_64 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install python-module-sip rpm package:
    # sudo apt-get install python-module-sip

Files

Path
/usr/bin/sip
/usr/lib64/python2.7/site-packages/sip.so
/usr/lib64/python2.7/site-packages/sip-4.19.13.dist-info/INSTALLER
/usr/lib64/python2.7/site-packages/sip-4.19.13.dist-info/METADATA
/usr/lib64/python2.7/site-packages/sip-4.19.13.dist-info/RECORD
/usr/share/doc/python-module-sip-4.19.13/LICENSE
/usr/share/doc/python-module-sip-4.19.13/LICENSE-GPL2
/usr/share/doc/python-module-sip-4.19.13/LICENSE-GPL3
/usr/share/doc/python-module-sip-4.19.13/NEWS
/usr/share/doc/python-module-sip-4.19.13/README

Changelog

2019-02-03 - Anton Midyukov <antohami@altlinux.org> 4.19.13-alt1
- new version (4.19.13) with rpmgs script
- build PyQt4 and PyQt5-sip modules
2018-08-22 - Sergey V Turchin <zerg@altlinux.org> 4.19.7-alt1.3
- move sipconfig and sipdistutils to devel subpackage
2018-08-22 - Sergey V Turchin <zerg@altlinux.org> 4.19.7-alt1.2
- move .pyi to devel subpackage
2018-03-22 - Aleksei Nikiforov <darktemplar@altlinux.org> 4.19.7-alt1.1
- (NMU) Rebuilt with python-3.6.4.
2018-02-14 - Vitaly Lipatov <lav@altlinux.ru> 4.19.7-alt1
- new version 4.19.7 (with rpmrb script)
2017-10-03 - Vitaly Lipatov <lav@altlinux.ru> 4.19.3-alt1
- new version (4.19.3) with rpmgs script
2016-04-02 - Ivan Zakharyaschev <imz@altlinux.org> 4.16.9-alt2
- (.spec) use updated correct %__python3_includedir and %__libpython3.
2016-01-28 - Mikhail Efremov <sem@altlinux.org> 4.16.9-alt1.1
- NMU: Use buildreq for BR.
2015-07-20 - Eugeny A. Rostovtsev (REAL) <real at altlinux.org> 4.16.9-alt1
- Version 4.16.9
2015-06-15 - Eugeny A. Rostovtsev (REAL) <real at altlinux.org> 4.16.8-alt1
- Version 4.16.8

See Also

Package Description
python-module-sip-devel-4.19.13-alt1.x86_64.rpm Header files for sip
python-module-sipsimple-3.4.2-alt1.x86_64.rpm SIP SIMPLE implementation for Python
python-module-smbc-1.0.15.3-alt1.1.1.x86_64.rpm Python interface for smbclient
python-module-smbpasswd-1.0.2-alt1.x86_64.rpm Python SMB Password Hash Generator module
python-module-snappy-0.5.3-alt2.x86_64.rpm Python library for the snappy compression library from Google
python-module-spidermonkey-0.0.10-alt4.1.2.x86_64.rpm JavaScript/python bridge
python-module-stfl-0.24-alt5.2.x86_64.rpm Python binding to stfl
python-module-strippers-0.9-alt3.x86_64.rpm Core files of strippers
python-module-strippers.facebook-0.9-alt3.x86_64.rpm Python library for Facebook Graph API
python-module-strippers.mixi-1.0-alt1.1.1.1.x86_64.rpm Python library for mixi Graph API
python-module-subprocess32-3.2.7-alt1.1.x86_64.rpm Backport of the subprocess module from Python 3.2/3.3 for use on 2.x
python-module-subvertpy-0.9.3-alt1.x86_64.rpm Python bindings for the Subversion version control system that are aimed to be complete, fast and feel native to Python programmers
python-module-subvertpy-doc-0.9.3-alt1.x86_64.rpm subvertpy documentation and example programs
python-module-svg-3.0-alt2.1.1.x86_64.rpm Core files of svg
python-module-svg.charts-3.0-alt2.1.1.x86_64.rpm Python SVG Charting Library
Advertisement
Advertisement