python-module-zope.hookable-4.0.4-alt1.1.1.1.x86_64.rpm


Advertisement

Description

python-module-zope.hookable - Hookable object support

Distribution: ALT Linux Sisyphus
Repository: Classic x86_64
Package name: python-module-zope.hookable
Package version: 4.0.4
Package release: alt1.1.1.1
Package architecture: x86_64
Package type: rpm
Installed size: 28.74 KB
Download size: 28.74 KB
Official Mirror: ftp.altlinux.org
Support the efficient creation of hookable objects, which are callable objects that are meant to be replaced by other callables, at least optionally. The idea is you create a function that does some default thing and make it hookable. Later, someone can modify what it does by calling its sethook method and changing its implementation. All users of the function, including those that imported it, will see the change.

Requires

Provides

  • python-module-zope.hookable = 4.0.4-alt1.1.1.1
  • python2.7(zope.hookable)
  • python2.7(zope.hookable._zope_hookable)

    Install Howto

    1. Add the following line to /etc/apt/sources.list:
      rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus x86_64 classic
      rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
      
    2. Update the package index:
      # sudo apt-get update
    3. Install python-module-zope.hookable rpm package:
      # sudo apt-get install python-module-zope.hookable

    Files

    • /usr/lib64/python2.7/site-packages/zope.hookable
    • /usr/lib64/python2.7/site-packages/zope/
    • /usr/lib64/python2.7/site-packages/zope.hookable-4.0.4-py2.7.egg-info/PKG-INFO
    • /usr/lib64/python2.7/site-packages/zope.hookable-4.0.4-py2.7.egg-info/SOURCES.txt
    • /usr/lib64/python2.7/site-packages/zope.hookable-4.0.4-py2.7.egg-info/dependency_links.txt
    • /usr/lib64/python2.7/site-packages/zope.hookable-4.0.4-py2.7.egg-info/namespace_packages.txt
    • /usr/lib64/python2.7/site-packages/zope.hookable-4.0.4-py2.7.egg-info/not-zip-safe
    • /usr/lib64/python2.7/site-packages/zope.hookable-4.0.4-py2.7.egg-info/requires.txt
    • /usr/lib64/python2.7/site-packages/zope.hookable-4.0.4-py2.7.egg-info/top_level.txt
    • /usr/lib64/python2.7/site-packages/zope/hookable/__init__.py
    • /usr/lib64/python2.7/site-packages/zope/hookable/__init__.pyc
    • /usr/lib64/python2.7/site-packages/zope/hookable/__init__.pyo
    • /usr/lib64/python2.7/site-packages/zope/hookable/_zope_hookable.c
    • /usr/lib64/python2.7/site-packages/zope/hookable/_zope_hookable.so
    • /usr/share/doc/python-module-zope.hookable-4.0.4/CHANGES.rst
    • /usr/share/doc/python-module-zope.hookable-4.0.4/COPYRIGHT.txt
    • /usr/share/doc/python-module-zope.hookable-4.0.4/LICENSE.txt
    • /usr/share/doc/python-module-zope.hookable-4.0.4/README.rst

    Changelog

    2016-03-18 - Ivan Zakharyaschev <imz@altlinux.org> 4.0.4-alt1.1.1.1 - (NMU) rebuild with python3-3.5 & rpm-build-python3-0.1.10 (for ABI dependence and new python3(*) reqs)

    2016-03-18 - Ivan Zakharyaschev <imz@altlinux.org> 4.0.4-alt1.1.1 - (NMU) rebuild with rpm-build-python3-0.1.9 (for common python3/site-packages/ and auto python3.3-ABI dep when needed)

    2016-01-29 - Mikhail Efremov <sem@altlinux.org> 4.0.4-alt1.1 - NMU: Use buildreq for BR.

    2014-07-24 - Eugeny A. Rostovtsev (REAL) <real at altlinux.org> 4.0.4-alt1 - Version 4.0.4 - Added module for Python 3

    2013-04-09 - Eugeny A. Rostovtsev (REAL) <real at altlinux.org> 4.0.1-alt1 - Version 4.0.1

    2012-04-12 - Vitaly Kuznetsov <vitty@altlinux.ru> 3.4.1-alt2.1.1 - Rebuild to remove redundant libpython2.7 dependency

    2011-10-20 - Vitaly Kuznetsov <vitty@altlinux.ru> 3.4.1-alt2.1 - Rebuild with Python-2.7

    2011-06-28 - Eugeny A. Rostovtsev (REAL) <real at altlinux.org> 3.4.1-alt2 - Added necessary requirements - Excluded *.pth

    2011-05-17 - Eugeny A. Rostovtsev (REAL) <real at altlinux.org> 3.4.1-alt1 - Initial build for Sisyphus

    Advertisement
    Advertisement